summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-08 14:00:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-08 14:00:40 +0000
commit253963a6a31218e6e964d53646793fd0bc920913 (patch)
treec5af814966aa7a3a66b3ce3dee7c63f97cbf7d78 /sys-power/yacpi
parentInitial commit wrt #163148 by Henning Schild. (diff)
downloadgentoo-2-253963a6a31218e6e964d53646793fd0bc920913.tar.gz
gentoo-2-253963a6a31218e6e964d53646793fd0bc920913.tar.bz2
gentoo-2-253963a6a31218e6e964d53646793fd0bc920913.zip
Initial commit wrt #163148 by Henning Schild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/yacpi')
-rw-r--r--sys-power/yacpi/ChangeLog9
-rw-r--r--sys-power/yacpi/metadata.xml9
-rw-r--r--sys-power/yacpi/yacpi-3.0.1.ebuild40
3 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/yacpi/ChangeLog b/sys-power/yacpi/ChangeLog
new file mode 100644
index 000000000000..67c2715cf441
--- /dev/null
+++ b/sys-power/yacpi/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-power/yacpi
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/yacpi/ChangeLog,v 1.1 2010/07/08 14:00:40 ssuominen Exp $
+
+*yacpi-3.0.1 (08 Jul 2010)
+
+ 08 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> +yacpi-3.0.1.ebuild:
+ Initial commit wrt #163148 by Henning Schild.
+
diff --git a/sys-power/yacpi/metadata.xml b/sys-power/yacpi/metadata.xml
new file mode 100644
index 000000000000..209f8444202c
--- /dev/null
+++ b/sys-power/yacpi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mobile</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-power/yacpi/yacpi-3.0.1.ebuild b/sys-power/yacpi/yacpi-3.0.1.ebuild
new file mode 100644
index 000000000000..b4b950d6e9a7
--- /dev/null
+++ b/sys-power/yacpi/yacpi-3.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/yacpi/yacpi-3.0.1.ebuild,v 1.1 2010/07/08 14:00:40 ssuominen Exp $
+
+EAPI=3
+inherit toolchain-funcs
+
+DESCRIPTION="Yet Another Configuration and Power Interface"
+HOMEPAGE="http://www.ngolde.de/yacpi.html"
+SRC_URI="http://www.ngolde.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/libacpi
+ sys-libs/ncurses"
+
+src_prepare() {
+ sed -i \
+ -e 's:= -O2 -Wall -g:+= -Wall:' \
+ -e 's:${CC} -Wall:${CC} ${LDFLAGS} ${CFLAGS}:' \
+ -e '/strip/d' \
+ -e 's:COPYING::' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ DOCPATH="${D}/usr/share/doc/${PF}" \
+ install || die
+
+ prepalldocs
+}