summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-20 22:42:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-20 22:42:21 +0000
commitc028ab05e10a3977adb29b93aef9edb6178b8b12 (patch)
tree0748ef9aa4c92d811ded3dae4af631fa43b54c89 /sys-process/audit
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-c028ab05e10a3977adb29b93aef9edb6178b8b12.tar.gz
gentoo-2-c028ab05e10a3977adb29b93aef9edb6178b8b12.tar.bz2
gentoo-2-c028ab05e10a3977adb29b93aef9edb6178b8b12.zip
Fix up some build issues with audit, LDAP is only needed for the z/OS plugin, Prelude support is not needed, and it fails to install docs due to a Makefile bug.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-process/audit')
-rw-r--r--sys-process/audit/ChangeLog8
-rw-r--r--sys-process/audit/audit-1.6.8.ebuild36
-rw-r--r--sys-process/audit/files/audit-1.6.8-subdirs-fix.patch12
3 files changed, 48 insertions, 8 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index 063ea20cf89c..8cd02dc839e3 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.38 2008/02/20 15:30:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.39 2008/02/20 22:42:21 robbat2 Exp $
+
+ 20 Feb 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/audit-1.6.8-subdirs-fix.patch, audit-1.6.8.ebuild:
+ Fix up some build issues with audit, LDAP is only needed for the z/OS
+ plugin, Prelude support is not needed, and it fails to install docs due to a
+ Makefile bug.
20 Feb 2008; Jeroen Roovers <jer@gentoo.org> audit-1.6.8.ebuild:
Marked ~hppa (bug #184563).
diff --git a/sys-process/audit/audit-1.6.8.ebuild b/sys-process/audit/audit-1.6.8.ebuild
index 329e058fb3d0..929ca647be92 100644
--- a/sys-process/audit/audit-1.6.8.ebuild
+++ b/sys-process/audit/audit-1.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.6.8.ebuild,v 1.2 2008/02/20 15:30:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.6.8.ebuild,v 1.3 2008/02/20 22:42:21 robbat2 Exp $
inherit autotools multilib toolchain-funcs python
@@ -11,9 +11,10 @@ SRC_URI="http://people.redhat.com/sgrubb/audit/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="ldap"
-RDEPEND=">=dev-lang/python-2.4"
+RDEPEND=">=dev-lang/python-2.4
+ ldap? ( net-nds/openldap )"
DEPEND="${RDEPEND}
dev-lang/swig
>=sys-kernel/linux-headers-2.6.22-r2"
@@ -30,23 +31,44 @@ src_unpack() {
#EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-swig-gcc-attribute.patch
# Do not build GUI tools
- sed -i -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' "${S}"/configure.ac
- sed -i -e 's,system-config-audit,,g' -e '/^SUBDIRS/s,\\$,,g' "${S}"/Makefile.am
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
+ "${S}"/configure.ac
+ sed -i \
+ -e 's,system-config-audit,,g' \
+ -e '/^SUBDIRS/s,\\$,,g' \
+ "${S}"/Makefile.am
rm -rf "${S}"/system-config-audit
+ # Probably goes away in 1.6.9
+ EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/audit-1.6.8-subdirs-fix.patch
+
+ if ! use ldap; then
+ sed -i \
+ -e '/^AC_OUTPUT/s,audisp/plugins/zos-remote/Makefile,,g' \
+ "${S}"/configure.ac
+ sed -i \
+ -e '/^SUBDIRS/s,zos-remote,,g' \
+ "${S}"/audisp/plugins/Makefile.am
+ fi
+
# Regenerate autotooling
eautoreconf
}
src_compile() {
#append-flags -D'__attribute__(x)='
- econf --sbindir=/sbin || die
+ econf --sbindir=/sbin --without-prelude || die
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README* THANKS TODO contrib/*
+ dodoc AUTHORS ChangeLog README* THANKS TODO
+ docinto contrib
+ dodoc contrib/*
+ docinto contrib/plugin
+ dodoc contrib/plugin/*
newinitd "${FILESDIR}"/auditd-init.d-1.2.3 auditd
newconfd "${FILESDIR}"/auditd-conf.d-1.2.3 auditd
diff --git a/sys-process/audit/files/audit-1.6.8-subdirs-fix.patch b/sys-process/audit/files/audit-1.6.8-subdirs-fix.patch
new file mode 100644
index 000000000000..662e376b40ed
--- /dev/null
+++ b/sys-process/audit/files/audit-1.6.8-subdirs-fix.patch
@@ -0,0 +1,12 @@
+--- audit-1.6.8/Makefile.am.orig 2008-02-20 14:33:51.034127088 -0800
++++ audit-1.6.8/Makefile.am 2008-02-20 14:33:57.640162864 -0800
+@@ -21,8 +21,7 @@
+ # Rickard E. (Rik) Faith <faith@redhat.com>
+ #
+
+-SUBDIRS = lib auparse src/mt src audisp tools swig bindings init.d
+- docs
++SUBDIRS = lib auparse src/mt src audisp tools swig bindings init.d docs
+ EXTRA_DIST = ChangeLog AUTHORS NEWS README README-install audit.spec \
+ contrib/capp.rules contrib/nispom.rules contrib/lspp.rules \
+ contrib/skeleton.c contrib/avc_snap contrib/avc_syslog \