summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-11-06 20:54:40 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-11-06 20:54:40 +0000
commit7e3c6ff225e772cff116c1246171a06150258d07 (patch)
tree58f598c82e7b76d19fe30e3b765aa842a8fdd392 /sys-process
parentAdd mercurial as alternative to quilt. Fixes bug 196523 by James Rowe <jnrowe... (diff)
downloadgentoo-2-7e3c6ff225e772cff116c1246171a06150258d07.tar.gz
gentoo-2-7e3c6ff225e772cff116c1246171a06150258d07.tar.bz2
gentoo-2-7e3c6ff225e772cff116c1246171a06150258d07.zip
Version bump, bug 442098
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/htop-1.0.2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 829d21752441..daeb72855976 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.124 2012/10/30 20:09:27 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.125 2012/11/06 20:54:39 idl0r Exp $
+
+*htop-1.0.2 (06 Nov 2012)
+
+ 06 Nov 2012; Christian Ruppert <idl0r@gentoo.org> +htop-1.0.2.ebuild:
+ Version bump, bug 442098
30 Oct 2012; Christian Ruppert <idl0r@gentoo.org> -htop-0.9-r2.ebuild,
-files/htop-0.9-debug.patch, -files/htop-0.9-small-width.patch,
diff --git a/sys-process/htop/htop-1.0.2.ebuild b/sys-process/htop/htop-1.0.2.ebuild
new file mode 100644
index 000000000000..54ea5740978b
--- /dev/null
+++ b/sys-process/htop/htop-1.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.2.ebuild,v 1.1 2012/11/06 20:54:40 idl0r Exp $
+
+EAPI=4
+
+# autotools for auto* dependencies
+inherit autotools
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ eerror
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ eerror
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ myconf=''
+
+ use kernel_FreeBSD && myconf="${myconf} --with-proc=/compat/linux/proc"
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats \
+ ${myconf}
+}