summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2008-11-02 17:39:43 +0000
committerJoshua Kinard <kumba@gentoo.org>2008-11-02 17:39:43 +0000
commit8c883911d473239c8adbe7b239a09683712d3ad9 (patch)
tree866b30ebdef2865102b37a740647528faeffc63f /sys-process
parentRemoving jmglov as a maintainer since he was retired. (diff)
downloadgentoo-2-8c883911d473239c8adbe7b239a09683712d3ad9.tar.gz
gentoo-2-8c883911d473239c8adbe7b239a09683712d3ad9.tar.bz2
gentoo-2-8c883911d473239c8adbe7b239a09683712d3ad9.zip
Bump lsof-4.81 to -r1 and include a patch to address Bug #244660.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.4-mipsgit-20081028 mips64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/ChangeLog8
-rw-r--r--sys-process/lsof/files/lsof-4.81-proc_c.patch20
-rw-r--r--sys-process/lsof/lsof-4.81-r1.ebuild (renamed from sys-process/lsof/lsof-4.81.ebuild)9
3 files changed, 34 insertions, 3 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index 513b06ff29d6..87354cb22f1e 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.51 2008/10/26 03:34:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.52 2008/11/02 17:39:43 kumba Exp $
+
+*lsof-4.81-r1 (02 Nov 2008)
+
+ 02 Nov 2008; Joshua Kinard <kumba@gentoo.org>
+ +files/lsof-4.81-proc_c.patch, -lsof-4.81.ebuild, +lsof-4.81-r1.ebuild:
+ Bump lsof-4.81 to -r1 and include a patch to address Bug #244660.
*lsof-4.81 (26 Oct 2008)
diff --git a/sys-process/lsof/files/lsof-4.81-proc_c.patch b/sys-process/lsof/files/lsof-4.81-proc_c.patch
new file mode 100644
index 000000000000..bfe491bdc77c
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.81-proc_c.patch
@@ -0,0 +1,20 @@
+*** /tmp/T0fSaqTh Sun Nov 2 07:48:14 2008
+--- proc.c Sun Nov 2 07:44:24 2008
+***************
+*** 841,847 ****
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if (((Selflags & SELNET) == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)
+--- 841,847 ----
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if ((Selflags == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)
+
diff --git a/sys-process/lsof/lsof-4.81.ebuild b/sys-process/lsof/lsof-4.81-r1.ebuild
index 0d371db49874..6c659ff8451d 100644
--- a/sys-process/lsof/lsof-4.81.ebuild
+++ b/sys-process/lsof/lsof-4.81-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.81.ebuild,v 1.1 2008/10/26 03:34:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.81-r1.ebuild,v 1.1 2008/11/02 17:39:43 kumba Exp $
inherit eutils flag-o-matic fixheadtails toolchain-funcs
@@ -24,9 +24,14 @@ src_unpack() {
unpack ${A}
cd ${MY_P}
unpack ./${MY_P}_src.tar
+ cd "${S}"
+
+ # Patch an over-zealous rejection of open-file listing when
+ # no options are specified on the command line and security
+ # options are enabled. Bug #244660
+ epatch "${FILESDIR}"/${P}-proc_c.patch
# now patch the scripts to automate everything
- cd "${S}"
ht_fix_file Configure Customize
touch .neverInv
epatch "${FILESDIR}"/${PN}-4.78-answer-config.patch