summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-02-22 20:52:53 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-02-22 20:52:53 +0000
commit257eb4652ae6e54d9a143a60d7537beb8358e29a (patch)
tree909ce16c4da9a12e3020e18608ff034a65977aa2 /www-apache/mod_caucho
parentchown /var/lib/postfix recursively - bug #405247 (diff)
downloadgentoo-2-257eb4652ae6e54d9a143a60d7537beb8358e29a.tar.gz
gentoo-2-257eb4652ae6e54d9a143a60d7537beb8358e29a.tar.bz2
gentoo-2-257eb4652ae6e54d9a143a60d7537beb8358e29a.zip
Fix bug #404533 and bug #405193: compilation without JDK and using LDFLAGS.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_caucho')
-rw-r--r--www-apache/mod_caucho/ChangeLog6
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.22.ebuild12
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.25.ebuild11
3 files changed, 22 insertions, 7 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index 96e84fa36e38..6434d69e9109 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.63 2012/02/17 18:12:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.64 2012/02/22 20:52:53 nelchael Exp $
+
+ 22 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org> mod_caucho-4.0.22.ebuild,
+ mod_caucho-4.0.25.ebuild:
+ Fix bug #404533 and bug #405193: compilation without JDK and using LDFLAGS.
17 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org> mod_caucho-4.0.22.ebuild,
mod_caucho-4.0.25.ebuild:
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild
index 882778e50525..d3f29e0129d8 100644
--- a/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild,v 1.2 2012/02/17 18:12:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild,v 1.3 2012/02/22 20:52:53 nelchael Exp $
EAPI="2"
@@ -34,7 +34,13 @@ src_prepare() {
epatch "${i}"
done
- sed -i -e 's,-m32,,g; s,-m64,,g;' configure.ac || die "sed failed"
+ sed -i \
+ -e 's,-m32,,g; s,-m64,,g;' \
+ -e '/.*Java 1.6 required.*/d' \
+ configure.ac || die "sed for configure.ac failed"
+ sed -i \
+ -e 's,\$(LIBS_SHLIB),$(LDFLAGS) $(LIBS_SHLIB),g' \
+ modules/c/src/apache2/Makefile.in || die "sed for Makefile.in failed"
mkdir m4
eautoreconf
@@ -42,7 +48,7 @@ src_prepare() {
}
src_configure() {
- econf --with-apxs=${APXS} || die "econf failed"
+ econf --with-apxs=${APXS} --with-java-home=/usr || die "econf failed"
}
src_compile() {
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild
index eb3856765a5a..2a4f0551c8d8 100644
--- a/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild,v 1.2 2012/02/17 18:12:41 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild,v 1.3 2012/02/22 20:52:53 nelchael Exp $
EAPI="2"
@@ -34,7 +34,12 @@ src_prepare() {
epatch "${i}"
done
- sed -i -e 's,-m32,,g; s,-m64,,g;' configure.ac || die "sed failed"
+ sed -i \
+ -e 's,-m32,,g; s,-m64,,g;' \
+ configure.ac || die "sed for configure.ac failed"
+ sed -i \
+ -e 's,\$(LIBS_SHLIB),$(LDFLAGS) $(LIBS_SHLIB),g' \
+ modules/c/src/apache2/Makefile.in || die "sed for Makefile.in failed"
mkdir m4
eautoreconf
@@ -42,7 +47,7 @@ src_prepare() {
}
src_configure() {
- econf --with-apxs=${APXS} || die "econf failed"
+ econf --with-apxs=${APXS} --with-java-home=/usr || die "econf failed"
}
src_compile() {