summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-08-24 16:45:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-08-24 16:45:02 +0000
commitd0859568a9277615e4d9da3d73e7b7688adb199a (patch)
tree117dc1cbca29ea5b91d313c2d908080477d64643 /www-apache
parentamd64 stable wrt bug #518244 (diff)
downloadgentoo-2-d0859568a9277615e4d9da3d73e7b7688adb199a.tar.gz
gentoo-2-d0859568a9277615e4d9da3d73e7b7688adb199a.tar.bz2
gentoo-2-d0859568a9277615e4d9da3d73e7b7688adb199a.zip
Bump to EAPI 5
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/libapreq2/ChangeLog10
-rw-r--r--www-apache/libapreq2/libapreq2-2.13-r1.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/www-apache/libapreq2/ChangeLog b/www-apache/libapreq2/ChangeLog
index e486110147ce..d41d0bd3b91c 100644
--- a/www-apache/libapreq2/ChangeLog
+++ b/www-apache/libapreq2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/libapreq2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/libapreq2/ChangeLog,v 1.48 2012/11/27 19:02:39 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/libapreq2/ChangeLog,v 1.49 2014/08/24 16:45:02 dilfridge Exp $
+
+*libapreq2-2.13-r1 (24 Aug 2014)
+
+ 24 Aug 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libapreq2-2.13-r1.ebuild:
+ Bump to EAPI 5
27 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop apache herd as discussed in http://www.gossamer-
diff --git a/www-apache/libapreq2/libapreq2-2.13-r1.ebuild b/www-apache/libapreq2/libapreq2-2.13-r1.ebuild
new file mode 100644
index 000000000000..e5a300f5022c
--- /dev/null
+++ b/www-apache/libapreq2/libapreq2-2.13-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/libapreq2/libapreq2-2.13-r1.ebuild,v 1.1 2014/08/24 16:45:02 dilfridge Exp $
+
+EAPI=5
+
+inherit apache-module perl-module multilib
+
+DESCRIPTION="A library for manipulating client request data via the Apache API"
+SRC_URI="mirror://apache/httpd/libapreq/${P}.tar.gz"
+HOMEPAGE="http://httpd.apache.org/apreq/"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="perl"
+
+DEPEND="${DEPEND}
+ perl? (
+ >=dev-perl/ExtUtils-XSBuilder-0.23
+ virtual/perl-version
+ >=www-apache/mod_perl-2
+ )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_FILE="module/apache2/.libs/mod_apreq2.so"
+APACHE2_MOD_CONF="76_mod_apreq"
+APACHE2_MOD_DEFINE="APREQ"
+DOCFILES="docs/html/*.html CHANGES README INSTALL MANIFEST"
+
+need_apache2
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/libapreq2-2.08-doc.patch
+
+ sed -i -e "s/PERL \$PERL_OPTS/PERL/" "${S}"/acinclude.m4 || die
+ sed -i -e "s/PERL \$PERL_OPTS/PERL/" "${S}"/aclocal.m4 || die
+ sed -i -e "s/PERL \$PERL_OPTS/PERL/" "${S}"/configure || die
+}
+
+src_configure() {
+ econf \
+ --with-apache2-apxs=${APXS} \
+ $(use_enable perl perl-glue)
+}
+
+src_install() {
+ apache-module_src_install
+
+ make DESTDIR="${D}" INSTALLDIRS=vendor install || die "make install failed"
+ doman docs/man/man3/*.3
+
+ fixlocalpod
+
+ for i in $(find "${D}" -type f -not -name '*.so'); do
+ if file ${i} | grep -i " text"; then
+ sed -i -e "s:${D}:/:g" ${i}
+ fi
+ done
+}