summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-06 04:24:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-06 04:24:15 +0000
commit1f4972b2171cce725809e53647e7a1490e6a9d18 (patch)
tree08da2c8558dfa098ae9e92c16597a4727b27c6c6 /www-apps/mantisbt
parentBump (diff)
downloadgentoo-2-1f4972b2171cce725809e53647e7a1490e6a9d18.tar.gz
gentoo-2-1f4972b2171cce725809e53647e7a1490e6a9d18.tar.bz2
gentoo-2-1f4972b2171cce725809e53647e7a1490e6a9d18.zip
Bump for #443106
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-apps/mantisbt')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/mantisbt-1.2.12.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 830aa8987dd7..3a850c414f22 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.119 2013/02/16 13:05:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.120 2013/03/06 04:24:15 patrick Exp $
+
+*mantisbt-1.2.12 (06 Mar 2013)
+
+ 06 Mar 2013; Patrick Lauer <patrick@gentoo.org> +mantisbt-1.2.12.ebuild:
+ Bump for #443106
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #96436
diff --git a/www-apps/mantisbt/mantisbt-1.2.12.ebuild b/www-apps/mantisbt/mantisbt-1.2.12.ebuild
new file mode 100644
index 000000000000..dcac7b641287
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.2.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.12.ebuild,v 1.1 2013/03/06 04:24:15 patrick Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php/ezc-Base-1.8
+ >=dev-php/ezc-Graph-1.5
+ >=dev-php/adodb-5.10"
+
+src_prepare() {
+ # Drop external libraries
+ rm -r "${S}/library/adodb/"
+ rm -r "${S}/library/ezc/"{Base,Graph}
+ sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \
+ -i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \
+ || die
+ # Fix incorrect filename
+ sed -e 's:config_default_inc.php:config_defaults_inc.php:' \
+ -i "${S}/lang/strings_russian.txt" || die
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+ webapp_src_install
+}