summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-12 17:13:04 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-12 17:13:04 +0000
commitcbde307458edf101196f3e9a0c87cf3c0f5cc26a (patch)
tree2e9eea367a868cefefdf07fc3dfd6f8001a58dbe /www-client/surf
parentStable for ppc, wrt bug #456540 (diff)
downloadgentoo-2-cbde307458edf101196f3e9a0c87cf3c0f5cc26a.tar.gz
gentoo-2-cbde307458edf101196f3e9a0c87cf3c0f5cc26a.tar.bz2
gentoo-2-cbde307458edf101196f3e9a0c87cf3c0f5cc26a.zip
Version bump.
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/ChangeLog9
-rw-r--r--www-client/surf/surf-0.6.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/www-client/surf/ChangeLog b/www-client/surf/ChangeLog
index a303fe8f6afc..880d50056720 100644
--- a/www-client/surf/ChangeLog
+++ b/www-client/surf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/surf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.23 2012/12/09 23:25:38 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.24 2013/02/12 17:13:04 jer Exp $
+
+*surf-0.6 (12 Feb 2013)
+
+ 12 Feb 2013; Jeroen Roovers <jer@gentoo.org> +surf-0.6.ebuild:
+ Version bump.
09 Dec 2012; Jeroen Roovers <jer@gentoo.org> surf-0.5.ebuild:
LICENSE should be "MIT" by Ulrich Müller (bug #446650).
diff --git a/www-client/surf/surf-0.6.ebuild b/www-client/surf/surf-0.6.ebuild
new file mode 100644
index 000000000000..ff04907eada8
--- /dev/null
+++ b/www-client/surf/surf-0.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6.ebuild,v 1.1 2013/02/12 17:13:04 jer Exp $
+
+EAPI=4
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+RDEPEND="
+ !sci-chemistry/surf
+ !savedconfig? ( net-misc/wget x11-terms/xterm )
+ x11-apps/xprop
+ x11-misc/dmenu
+ ${DEPEND}
+"
+
+pkg_setup() {
+ elog "net-misc/wget and x11-terms/xterm will be installed by default to"
+ elog "support the default download command, which can be changed through"
+ elog "the savedconfig mechanism. If you enable USE=savedconfig, you will"
+ elog "need to satisfy requirements for the alternative download command"
+ elog "yourself."
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|{|(|g;s|}|)|g' \
+ -e 's|\t@|\t|g;s|echo|@&|g' \
+ -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^CC.*|CC ?= gcc|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ config.mk Makefile || die "sed failed"
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ save_config config.h
+}
+
+pkg_postinst() {
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+}