summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-11 15:43:03 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-11 15:43:03 +0000
commit3db08189b766c877618dd238f5923a25c0f5c9b9 (patch)
tree61b2ca28025790df05b33a01c55e415b2cb7e7d1 /x11-drivers/xf86-video-chips
parentsci-biology/kalign: Drop Andrey as maintainer so that bugs get assigned to sc... (diff)
downloadgentoo-2-3db08189b766c877618dd238f5923a25c0f5c9b9.tar.gz
gentoo-2-3db08189b766c877618dd238f5923a25c0f5c9b9.tar.bz2
gentoo-2-3db08189b766c877618dd238f5923a25c0f5c9b9.zip
Fix building against xorg-server-1.14, bug #461236.
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-video-chips')
-rw-r--r--x11-drivers/xf86-video-chips/ChangeLog11
-rw-r--r--x11-drivers/xf86-video-chips/files/xf86-video-chips-1.2.5-remove-mibstore_h.patch39
-rw-r--r--x11-drivers/xf86-video-chips/xf86-video-chips-1.2.5-r1.ebuild16
3 files changed, 64 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-chips/ChangeLog b/x11-drivers/xf86-video-chips/ChangeLog
index a00547a0544b..3384a4e7b23e 100644
--- a/x11-drivers/xf86-video-chips/ChangeLog
+++ b/x11-drivers/xf86-video-chips/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-chips
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-chips/ChangeLog,v 1.59 2012/12/28 11:10:46 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-chips/ChangeLog,v 1.60 2013/03/11 15:43:03 chithanh Exp $
+
+*xf86-video-chips-1.2.5-r1 (11 Mar 2013)
+
+ 11 Mar 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-chips-1.2.5-remove-mibstore_h.patch,
+ +xf86-video-chips-1.2.5-r1.ebuild:
+ Fix building against xorg-server-1.14, bug #461236.
28 Dec 2012; Agostino Sarubbo <ago@gentoo.org> xf86-video-chips-1.2.5.ebuild:
Stable for ia64, wrt bug #440872
diff --git a/x11-drivers/xf86-video-chips/files/xf86-video-chips-1.2.5-remove-mibstore_h.patch b/x11-drivers/xf86-video-chips/files/xf86-video-chips-1.2.5-remove-mibstore_h.patch
new file mode 100644
index 000000000000..bfd94181e9f8
--- /dev/null
+++ b/x11-drivers/xf86-video-chips/files/xf86-video-chips-1.2.5-remove-mibstore_h.patch
@@ -0,0 +1,39 @@
+From 151a1ec855a9ada44907cb6bef06a71e9080504b Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:34 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/ct_driver.c b/src/ct_driver.c
+index 6f3a5d4..effbc60 100644
+--- a/src/ct_driver.c
++++ b/src/ct_driver.c
+@@ -96,9 +96,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi banking wrapper need this */
+ #ifdef HAVE_ISA
+ #include "mibank.h"
+@@ -4145,7 +4142,6 @@ CHIPSScreenInit(SCREEN_INIT_ARGS_DECL)
+ pBankInfo = NULL;
+ return FALSE;
+ }
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+
+ /* Initialise cursor functions */
+@@ -4296,7 +4292,6 @@ CHIPSScreenInit(SCREEN_INIT_ARGS_DECL)
+ }
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ #ifdef ENABLE_SILKEN_MOUSE
+ xf86SetSilkenMouse(pScreen);
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-chips/xf86-video-chips-1.2.5-r1.ebuild b/x11-drivers/xf86-video-chips/xf86-video-chips-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..3b1704d17b14
--- /dev/null
+++ b/x11-drivers/xf86-video-chips/xf86-video-chips-1.2.5-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-chips/xf86-video-chips-1.2.5-r1.ebuild,v 1.1 2013/03/11 15:43:03 chithanh Exp $
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="Chips and Technologies video driver"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-mibstore_h.patch
+)