summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-17 16:32:08 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-17 16:32:08 +0000
commit2ea5bf60f0e109f733014b0de5b58938b035e8a3 (patch)
tree50e974b080244ca6497ec39d173c3cdeacf260e3 /x11-drivers/xf86-video-openchrome
parentFix manifest for selinux-phpfpm (diff)
downloadgentoo-2-2ea5bf60f0e109f733014b0de5b58938b035e8a3.tar.gz
gentoo-2-2ea5bf60f0e109f733014b0de5b58938b035e8a3.tar.bz2
gentoo-2-2ea5bf60f0e109f733014b0de5b58938b035e8a3.zip
Fix a segmentation fault while running in xorg 1.12 (Debian bug #675407).
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-openchrome')
-rw-r--r--x11-drivers/xf86-video-openchrome/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-openchrome/files/xf86-video-openchrome-0.2.906-xorg-1.12.patch32
-rw-r--r--x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild8
3 files changed, 44 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-openchrome/ChangeLog b/x11-drivers/xf86-video-openchrome/ChangeLog
index 99991845a104..8dfa0dcd726a 100644
--- a/x11-drivers/xf86-video-openchrome/ChangeLog
+++ b/x11-drivers/xf86-video-openchrome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-openchrome
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-openchrome/ChangeLog,v 1.61 2012/06/24 11:16:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-openchrome/ChangeLog,v 1.62 2012/07/17 16:32:06 jer Exp $
+
+ 17 Jul 2012; Jeroen Roovers <jer@gentoo.org>
+ xf86-video-openchrome-0.2.906.ebuild,
+ +files/xf86-video-openchrome-0.2.906-xorg-1.12.patch:
+ Fix a segmentation fault while running in xorg 1.12 (Debian bug #675407).
24 Jun 2012; Agostino Sarubbo <ago@gentoo.org>
xf86-video-openchrome-0.2.906.ebuild:
diff --git a/x11-drivers/xf86-video-openchrome/files/xf86-video-openchrome-0.2.906-xorg-1.12.patch b/x11-drivers/xf86-video-openchrome/files/xf86-video-openchrome-0.2.906-xorg-1.12.patch
new file mode 100644
index 000000000000..1c39353fb231
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/files/xf86-video-openchrome-0.2.906-xorg-1.12.patch
@@ -0,0 +1,32 @@
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=675407
+
+
+Deal with X 1.12 by calling vgaHWSetStdFuncs().
+
+Thanks to Leon Winter for testing the initial patch and proposing a
+working one.
+
+Signed-off-by: Cyril Brulebois <kibi@debian.org>
+--- a/src/via_driver.c
++++ b/src/via_driver.c
+@@ -997,6 +997,11 @@ VIAPreInit(ScrnInfoPtr pScrn, int flags)
+ #endif
+ }
+
++ hwp = VGAHWPTR(pScrn);
++
++ /* Needed with X 1.12 */
++ vgaHWSetStdFuncs(hwp);
++
+ if (pVia->Chipset == VIA_CLE266)
+ ViaDoubleCheckCLE266Revision(pScrn);
+
+@@ -1012,8 +1017,6 @@ VIAPreInit(ScrnInfoPtr pScrn, int flags)
+ struct pci_device *vgaDevice = viaPciDeviceVga();
+ #endif
+
+- hwp = VGAHWPTR(pScrn);
+-
+ switch (pVia->Chipset) {
+ case VIA_CLE266:
+ #ifdef XSERVER_LIBPCIACCESS
diff --git a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild
index 937559f45853..723e0f29e451 100644
--- a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild
+++ b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild,v 1.3 2012/06/24 11:16:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.2.906.ebuild,v 1.4 2012/07/17 16:32:06 jer Exp $
EAPI=4
XORG_DRI="dri"
-inherit xorg-2
+inherit eutils xorg-2
DESCRIPTION="X.Org driver for VIA/S3G cards"
HOMEPAGE="http://www.openchrome.org"
@@ -26,6 +26,10 @@ DEPEND="
DOCS=( ChangeLog NEWS README )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-xorg-1.12.patch
+}
+
pkg_setup() {
xorg-2_pkg_setup
XORG_CONFIGURE_OPTIONS=(