summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-05-31 21:35:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-05-31 21:35:58 +0000
commit132cafcd750b28e11e0e9c3c093cd07e0c09d30e (patch)
treea2ae7523a7b96d2ef583f80b76ae579a6dce9fce /x11-libs/goffice
parentRemove vulnerable version as per Alex "a3li" Legler in security bug #295270. (diff)
downloadgentoo-2-132cafcd750b28e11e0e9c3c093cd07e0c09d30e.tar.gz
gentoo-2-132cafcd750b28e11e0e9c3c093cd07e0c09d30e.tar.bz2
gentoo-2-132cafcd750b28e11e0e9c3c093cd07e0c09d30e.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/ChangeLog7
-rw-r--r--x11-libs/goffice/goffice-0.8.5.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index 3024ecd90a0e..d4bec21c16e8 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goffice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.67 2010/05/16 10:02:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.68 2010/05/31 21:35:58 eva Exp $
+
+*goffice-0.8.5 (31 May 2010)
+
+ 31 May 2010; Gilles Dartiguelongue <eva@gentoo.org> +goffice-0.8.5.ebuild:
+ Version bump.
16 May 2010; Gilles Dartiguelongue <eva@gentoo.org> goffice-0.8.3.ebuild:
Fix intltool rules, bug #319051.
diff --git a/x11-libs/goffice/goffice-0.8.5.ebuild b/x11-libs/goffice/goffice-0.8.5.ebuild
new file mode 100644
index 000000000000..037e68c03ead
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.8.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.5.ebuild,v 1.1 2010/05/31 21:35:58 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="doc gnome"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND=">=dev-libs/glib-2.16
+ >=gnome-extra/libgsf-1.14.9[gnome?]
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/cairo-1.2[svg]
+ x11-libs/libXext
+ x11-libs/libXrender
+ >=x11-libs/gtk+-2.16
+ gnome? ( >=gnome-base/gconf-2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --without-lasem
+ --with-gtk
+ $(use_with gnome gconf)"
+ filter-flags -ffast-math
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die
+}