summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-02-11 23:17:21 +0000
committerBen de Groot <yngwin@gentoo.org>2009-02-11 23:17:21 +0000
commit69a92e4d5e3117daa37e3ed6ed8090478bfe5692 (patch)
tree66d9eb344149e5a7eb2b62555b26c88df472c34a /x11-libs/qt-opengl
parentQt 4.5.0_rc1 version bump (diff)
downloadgentoo-2-69a92e4d5e3117daa37e3ed6ed8090478bfe5692.tar.gz
gentoo-2-69a92e4d5e3117daa37e3ed6ed8090478bfe5692.tar.bz2
gentoo-2-69a92e4d5e3117daa37e3ed6ed8090478bfe5692.zip
Qt 4.5.0_rc1 version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.5.0_rc1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index c78e1aa66789..1c7bf1e981ad 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.21 2009/02/06 16:27:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.22 2009/02/11 23:17:21 yngwin Exp $
+
+*qt-opengl-4.5.0_rc1 (11 Feb 2009)
+
+ 11 Feb 2009; Ben de Groot <yngwin@gentoo.org> +qt-opengl-4.5.0_rc1.ebuild:
+ Version bump
06 Feb 2009; Raúl Porcel <armin76@gentoo.org> qt-opengl-4.4.2.ebuild:
ia64/sparc stable wrt #248038
diff --git a/x11-libs/qt-opengl/qt-opengl-4.5.0_rc1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.5.0_rc1.ebuild
new file mode 100644
index 000000000000..e096b93d3140
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.5.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.5.0_rc1.ebuild,v 1.1 2009/02/11 23:17:21 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/opengl"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}