summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-10 11:54:10 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-10 11:54:10 +0000
commit3f552eb07a6d3fcdf7b55da08eb5d9da586ec123 (patch)
treeb30cedbc65a9b9f27e2d59634255495cb8903169 /x11-libs
parentCheck for NULL pointer in response from conversation function, bug 407591. (diff)
downloadgentoo-2-3f552eb07a6d3fcdf7b55da08eb5d9da586ec123.tar.gz
gentoo-2-3f552eb07a6d3fcdf7b55da08eb5d9da586ec123.tar.bz2
gentoo-2-3f552eb07a6d3fcdf7b55da08eb5d9da586ec123.zip
Add fix for underlinking detected by gold
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goocanvas/ChangeLog6
-rw-r--r--x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch30
-rw-r--r--x11-libs/goocanvas/goocanvas-2.0.1.ebuild3
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index ca356b94ccb6..da0cd7f16e10 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/goocanvas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.26 2012/01/15 14:12:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.27 2012/03/10 11:54:10 jlec Exp $
+
+ 10 Mar 2012; Justin Lecher <jlec@gentoo.org> goocanvas-2.0.1.ebuild,
+ +files/goocanvas-2.0.1-gold.patch:
+ Add fix for underlinking detected by gold
15 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> goocanvas-2.0.1.ebuild:
Empty py-compile script instead of symlinking it to /path/to/true for
diff --git a/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch b/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch
new file mode 100644
index 000000000000..c37dc4efef89
--- /dev/null
+++ b/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch
@@ -0,0 +1,30 @@
+ src/Makefile.am | 2 +-
+ src/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2052baa..e5d9693 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -12,7 +12,7 @@ INCLUDES = \
+
+ lib_LTLIBRARIES = libgoocanvas-2.0.la
+
+-libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+
+ if PLATFORM_WIN32
+ no_undefined = -no-undefined
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 1d927b9..15b9316 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -297,7 +297,7 @@ INCLUDES = \
+ # -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ # -DGTK_DISABLE_DEPRECATED
+ lib_LTLIBRARIES = libgoocanvas-2.0.la
+-libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+ @PLATFORM_WIN32_TRUE@no_undefined = -no-undefined
+ libtool_opts = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/x11-libs/goocanvas/goocanvas-2.0.1.ebuild b/x11-libs/goocanvas/goocanvas-2.0.1.ebuild
index cb30b33b027c..531ad253e8e3 100644
--- a/x11-libs/goocanvas/goocanvas-2.0.1.ebuild
+++ b/x11-libs/goocanvas/goocanvas-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-2.0.1.ebuild,v 1.2 2012/01/15 14:12:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-2.0.1.ebuild,v 1.3 2012/03/10 11:54:10 jlec Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -44,6 +44,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gold.patch
# Do not build demos
sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die "sed failed"