summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2006-01-07 07:09:33 +0000
committerJoe McCann <joem@gentoo.org>2006-01-07 07:09:33 +0000
commit8b17099d64b0f8eeb832822849dd6688b84b890e (patch)
tree3eb8ecf7e241abfb066eab0b987de6e3f5766243 /x11-libs
parentCleanup ebuild and fix building when xv is disabled. (diff)
downloadgentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.tar.gz
gentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.tar.bz2
gentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.zip
version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/ChangeLog9
-rw-r--r--x11-libs/goffice/Manifest16
-rw-r--r--x11-libs/goffice/files/digest-goffice-0.1.21
-rw-r--r--x11-libs/goffice/goffice-0.1.2.ebuild45
4 files changed, 57 insertions, 14 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index a0d7303fe4a4..b6aa8cb70f32 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goffice
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.7 2005/11/01 15:58:02 yoswink Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.8 2006/01/07 07:09:33 joem Exp $
+
+*goffice-0.1.2 (07 Jan 2006)
+
+ 07 Jan 2006; Joe McCann <joem@gentoo.org> +goffice-0.1.2.ebuild:
+ new version
01 Nov 2005; Jose Luis Rivero <yoswink@gentoo.org> goffice-0.1.0.ebuild:
Added ~alpha keyword wrt bug #110858
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 9ca4a3a5779c..053d166ac86a 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c64dfddbf2ed47739b05cdbd4ca4e939 goffice-0.1.0.ebuild 1269
MD5 b12e11e6e295913bacd6079380ecf730 ChangeLog 1186
-MD5 9223ce07181892826a7663eb673f91f3 metadata.xml 436
MD5 0d5535797dbf42513d9f390cdb6d31f0 files/digest-goffice-0.1.0 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDZ5S23og80iZgVQgRAo2MAKCdyUXAUbBPNbO8h5XaFki6xaziVQCeJudj
-UcsHNyhOh3YFquFnc2RSODk=
-=ky1X
------END PGP SIGNATURE-----
+MD5 c332ae77d8f80613f7580d1c359fb778 files/digest-goffice-0.1.2 67
+MD5 c64dfddbf2ed47739b05cdbd4ca4e939 goffice-0.1.0.ebuild 1269
+MD5 6ed957a66105e1982e69adbe132a9bc5 goffice-0.1.2.ebuild 1269
+MD5 9223ce07181892826a7663eb673f91f3 metadata.xml 436
diff --git a/x11-libs/goffice/files/digest-goffice-0.1.2 b/x11-libs/goffice/files/digest-goffice-0.1.2
new file mode 100644
index 000000000000..6c2d8bedd915
--- /dev/null
+++ b/x11-libs/goffice/files/digest-goffice-0.1.2
@@ -0,0 +1 @@
+MD5 74de4548603a35f8cdf95b52ac31d8c6 goffice-0.1.2.tar.bz2 1410910
diff --git a/x11-libs/goffice/goffice-0.1.2.ebuild b/x11-libs/goffice/goffice-0.1.2.ebuild
new file mode 100644
index 000000000000..7555d17d256b
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.1.2.ebuild,v 1.1 2006/01/07 07:09:33 joem Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome"
+#cairo support broken and -gtk broken
+
+RDEPEND=">=dev-libs/glib-2.6.3
+ >=gnome-extra/libgsf-1.13.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/libgnomeprint-2.8.2
+ >=media-libs/libart_lgpl-2.3.11
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+USE_DESTDIR="1"
+
+
+pkg_setup() {
+ G2CONF="$(use_with gnome)"
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "Please rebuild gnome-extra/libgsf with gnome support enabled"
+ eerror "USE=\"gnome\" emerge gnome-extra/libgsf"
+ eerror "or add \"gnome\" to your USE string in /etc/make.conf"
+ die "No Gnome support found in libgsf"
+ fi
+}