summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-11-27 21:06:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-11-27 21:06:40 +0000
commitc2150d192dff6517bd9ffcb14d085cdc8e8e6879 (patch)
tree39bce8e9c4e72d53398508f53a5a553c267e28a2 /x11-libs
parentAdd a samba.service unit file (#490394 by Daniel Klaffenbach) (diff)
downloadgentoo-2-c2150d192dff6517bd9ffcb14d085cdc8e8e6879.tar.gz
gentoo-2-c2150d192dff6517bd9ffcb14d085cdc8e8e6879.tar.bz2
gentoo-2-c2150d192dff6517bd9ffcb14d085cdc8e8e6879.zip
fix build with graphviz 2.34
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/flowcanvas/ChangeLog8
-rw-r--r--x11-libs/flowcanvas/files/gv234.patch48
-rw-r--r--x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild5
3 files changed, 57 insertions, 4 deletions
diff --git a/x11-libs/flowcanvas/ChangeLog b/x11-libs/flowcanvas/ChangeLog
index ffd9d2c7e1ae..53a5edcbce9b 100644
--- a/x11-libs/flowcanvas/ChangeLog
+++ b/x11-libs/flowcanvas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/flowcanvas
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.16 2012/06/01 20:40:07 axs Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.17 2013/11/27 21:06:39 aballier Exp $
+
+ 27 Nov 2013; Alexis Ballier <aballier@gentoo.org> flowcanvas-0.7.1.ebuild,
+ +files/gv234.patch:
+ fix build with graphviz 2.34
01 Jun 2012; Ian Stakenvicius <axs@gentoo.org> -flowcanvas-0.5.1.ebuild,
-flowcanvas-0.6.0.ebuild, -flowcanvas-0.6.4.ebuild, -files/ldconfig.patch:
diff --git a/x11-libs/flowcanvas/files/gv234.patch b/x11-libs/flowcanvas/files/gv234.patch
new file mode 100644
index 000000000000..ec03696135c0
--- /dev/null
+++ b/x11-libs/flowcanvas/files/gv234.patch
@@ -0,0 +1,48 @@
+Index: flowcanvas-0.7.1/src/Canvas.cpp
+===================================================================
+--- flowcanvas-0.7.1.orig/src/Canvas.cpp
++++ flowcanvas-0.7.1/src/Canvas.cpp
+@@ -1253,21 +1253,21 @@ Canvas::layout_dot(bool use_length_hints
+ */
+
+ GVC_t* gvc = gvContext();
+- Agraph_t* G = agopen((char*)"g", AGDIGRAPH);
++ Agraph_t* G = agopen((char*)"g", Agdirected, 0);
+
+ nodes.gvc = gvc;
+ nodes.G = G;
+
+ if (_direction == HORIZONTAL)
+- agraphattr(G, (char*)"rankdir", (char*)"LR");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"LR");
+ else
+- agraphattr(G, (char*)"rankdir", (char*)"TD");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"TD");
+
+ unsigned id = 0;
+ for (ItemList::const_iterator i = _items.begin(); i != _items.end(); ++i) {
+ std::ostringstream ss;
+ ss << "n" << id++;
+- Agnode_t* node = agnode(G, strdup(ss.str().c_str()));
++ Agnode_t* node = agnode(G, strdup(ss.str().c_str()), 1);
+ if (boost::dynamic_pointer_cast<Module>(*i)) {
+ ss.str("");
+ ss << (*i)->width() / 96.0;
+@@ -1310,7 +1310,7 @@ Canvas::layout_dot(bool use_length_hints
+
+ assert(src_node && dst_node);
+
+- Agedge_t* edge = agedge(G, src_node, dst_node);
++ Agedge_t* edge = agedge(G, src_node, dst_node, NULL, 1);
+
+ if (use_length_hints && c->length_hint() != 0) {
+ std::ostringstream len_ss;
+@@ -1325,7 +1325,7 @@ Canvas::layout_dot(bool use_length_hints
+ if (partner) {
+ GVNodes::iterator p = nodes.find(partner);
+ if (p != nodes.end())
+- agedge(G, i->second, p->second);
++ agedge(G, i->second, p->second, NULL, 1);
+ }
+ }
+
diff --git a/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild b/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild
index 4a373b445be1..a1856b81ead3 100644
--- a/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild
+++ b/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild,v 1.6 2012/06/01 19:59:46 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild,v 1.7 2013/11/27 21:06:39 aballier Exp $
EAPI=4
@@ -32,6 +32,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/ldconfig2.patch"
+ has_version '>=media-gfx/graphviz-2.34' && epatch "${FILESDIR}/gv234.patch"
}
src_configure() {