summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-11 01:04:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-11 01:04:52 +0000
commitdd541c0b76bd3d00d9b5461806317ff561ff3302 (patch)
tree5e045f682be992694edd650de203591443b11257 /x11-libs
parentSLOT fix in 2.3.1. Added ~ppc, ~sparc, ~alpha and ~hppa to 2.4.0. (diff)
downloadgentoo-2-dd541c0b76bd3d00d9b5461806317ff561ff3302.tar.gz
gentoo-2-dd541c0b76bd3d00d9b5461806317ff561ff3302.tar.bz2
gentoo-2-dd541c0b76bd3d00d9b5461806317ff561ff3302.zip
switch to use_enable and other cleanups. Thanks to Charles Allen <crallen@purdue.edu> in bug #37698 for pointing out why use_enable should be used
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gai/ChangeLog9
-rw-r--r--x11-libs/gai/Manifest4
-rw-r--r--x11-libs/gai/gai-0.5.0_pre6.ebuild31
3 files changed, 24 insertions, 20 deletions
diff --git a/x11-libs/gai/ChangeLog b/x11-libs/gai/ChangeLog
index f0739a17ec07..ebc6788368e6 100644
--- a/x11-libs/gai/ChangeLog
+++ b/x11-libs/gai/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gai
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.1 2003/12/10 11:42:24 lordvan Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.2 2004/01/11 01:04:35 seemant Exp $
+
+ 10 Jan 2004; Seemant Kulleen <seemant@gentoo.org> gai-0.5.0_pre6.ebuild:
+ switch to use_enable and other cleanups. Thanks to Charles Allen
+ <crallen@purdue.edu> in bug #37698 for pointing out why use_enable should be
+ used
*gai-0.5.0_pre6 (10 Dec 2003)
diff --git a/x11-libs/gai/Manifest b/x11-libs/gai/Manifest
index a34368c3d4fd..993b503dbd06 100644
--- a/x11-libs/gai/Manifest
+++ b/x11-libs/gai/Manifest
@@ -1,4 +1,4 @@
-MD5 4df0e762f91cab53f20910e160ddf619 gai-0.5.0_pre6.ebuild 1182
-MD5 a97af9566319a7041d42e9fd724d323f ChangeLog 358
+MD5 06d0869c7f67cb7a9fcadfed475179c6 gai-0.5.0_pre6.ebuild 1049
+MD5 2d25da72176a39fc82850e991966c1b0 ChangeLog 587
MD5 4de810beafe6af976494dfe29abd5c60 metadata.xml 405
MD5 2cc1df4e270e1be3a526f9609c89accc files/digest-gai-0.5.0_pre6 66
diff --git a/x11-libs/gai/gai-0.5.0_pre6.ebuild b/x11-libs/gai/gai-0.5.0_pre6.ebuild
index 7db7d886e444..1c25041de228 100644
--- a/x11-libs/gai/gai-0.5.0_pre6.ebuild
+++ b/x11-libs/gai/gai-0.5.0_pre6.ebuild
@@ -1,32 +1,31 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.0_pre6.ebuild,v 1.1 2003/12/10 11:42:24 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.0_pre6.ebuild,v 1.2 2004/01/11 01:04:35 seemant Exp $
-MY_PV="0.5.0pre6"
-MY_P="${PN}-${MY_PV}"
+IUSE="opengl gnome"
+
+MY_P=${P/_/}
DESCRIPTION="GAI, The General Applet Interface library is a library that will help applet programmers alot."
HOMEPAGE="http://gai.sourceforge.net/"
SRC_URI="mirror://sourceforge/gai/${MY_P}.tar.bz2"
-LICENSE="LGPL-2"
+
SLOT="0"
+LICENSE="LGPL-2"
KEYWORDS="~x86"
-IUSE="opengl gnome"
+
DEPEND=">=x11-libs/gtk+-2.0.0
-opengl? ( >=x11-libs/gtkglext-1.0.5 )
-gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
+ opengl? ( >=x11-libs/gtkglext-1.0.5 )
+ gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
S=${WORKDIR}/${MY_P}
src_compile() {
# works with just set prefix (doesn't hardcode the prefix anywhere)!
- MY_CONF="--prefix=${D}/usr "
- if [ ! "`use opengl`" ]; then
- MY_CONF="${MY_CONF} --disable-gl"
- fi
- if [ ! "`use gnome`" ]; then
- MY_CONF="${MY_CONF} --diable-gnome"
- fi
- econf ${MY_CONF} || die
+ econf \
+ --prefix=${D}/usr \
+ `use_enable opengl gl` \
+ `use_enable gnome` || die
+
emake || die
}