summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-10 09:39:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-10 09:39:13 +0000
commit0a158ea1183257a8598193bd91b8fe5651fcdd9e (patch)
treee55c0b50a2a20ac19d7efc62cd77764a5c8f5e39 /x11-misc/hsetroot
parentFix no-lib-symlinking build failure wrt bug#503624. Thanks to Georgi Georgiev... (diff)
downloadgentoo-2-0a158ea1183257a8598193bd91b8fe5651fcdd9e.tar.gz
gentoo-2-0a158ea1183257a8598193bd91b8fe5651fcdd9e.tar.bz2
gentoo-2-0a158ea1183257a8598193bd91b8fe5651fcdd9e.zip
Use pkg-config to get $(X11_LIBS) for the hsetroot binary in src/Makefile.am wrt #504056 by techno156
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-misc/hsetroot')
-rw-r--r--x11-misc/hsetroot/ChangeLog10
-rw-r--r--x11-misc/hsetroot/files/hsetroot-1.0.2-underlinking.patch24
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.2.ebuild18
3 files changed, 39 insertions, 13 deletions
diff --git a/x11-misc/hsetroot/ChangeLog b/x11-misc/hsetroot/ChangeLog
index 17d6a8bd15fd..28648a7e54d7 100644
--- a/x11-misc/hsetroot/ChangeLog
+++ b/x11-misc/hsetroot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/hsetroot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hsetroot/ChangeLog,v 1.13 2012/06/04 20:13:08 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hsetroot/ChangeLog,v 1.14 2014/03/10 09:39:12 ssuominen Exp $
+
+ 10 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/hsetroot-1.0.2-underlinking.patch, hsetroot-1.0.2.ebuild:
+ Use pkg-config to get $(X11_LIBS) for the hsetroot binary in src/Makefile.am
+ wrt #504056 by techno156
04 Jun 2012; Michael Weber <xmw@gentoo.org> hsetroot-1.0.2.ebuild:
Fix SRC_URI/HOMEPAGE (reported by df, bug 416293)
@@ -43,4 +48,3 @@
05 Dec 2004; <pyrania@gentoo.org> +metadata.xml, +hsetroot-1.0.2.ebuild:
Initial import.
-
diff --git a/x11-misc/hsetroot/files/hsetroot-1.0.2-underlinking.patch b/x11-misc/hsetroot/files/hsetroot-1.0.2-underlinking.patch
new file mode 100644
index 000000000000..8d87a48fb805
--- /dev/null
+++ b/x11-misc/hsetroot/files/hsetroot-1.0.2-underlinking.patch
@@ -0,0 +1,24 @@
+http://bugs.gentoo.org/504056
+
+--- configure.ac
++++ configure.ac
+@@ -38,6 +38,8 @@
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+
++PKG_CHECK_MODULES(X11, [x11])
++
+ # Check for imlib2
+ AC_CHECK_PROGS(imlib2config_cmd, imlib2-config)
+ if test x$imlib2config_cmd = "x"; then
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = hsetroot
+
+ AM_CFLAGS = @CFLAGS@ @IMLIB2_CFLAGS@ -Wall
+-LIBS = @IMLIB2_LIBS@
++LIBS = @IMLIB2_LIBS@ $(X11_LIBS)
+
+ hsetroot_SOURCES = hsetroot.c
+
diff --git a/x11-misc/hsetroot/hsetroot-1.0.2.ebuild b/x11-misc/hsetroot/hsetroot-1.0.2.ebuild
index a05cae9c35ec..2d66ca534f35 100644
--- a/x11-misc/hsetroot/hsetroot-1.0.2.ebuild
+++ b/x11-misc/hsetroot/hsetroot-1.0.2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hsetroot/hsetroot-1.0.2.ebuild,v 1.15 2012/06/04 20:13:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hsetroot/hsetroot-1.0.2.ebuild,v 1.16 2014/03/10 09:39:12 ssuominen Exp $
-EAPI="2"
-
-inherit autotools
+EAPI=5
+inherit autotools eutils
DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
HOMEPAGE="http://thegraveyard.org/hsetroot.html"
@@ -18,14 +17,13 @@ IUSE=""
RDEPEND="x11-libs/libX11
>=media-libs/imlib2-1.0.6.2003[X]"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
x11-proto/xproto"
+DOCS="AUTHORS ChangeLog NEWS README"
+
src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
# The pre-generated configure script contains unneeded deps
eautoreconf
}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog NEWS README || die
-}