summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-06-13 18:34:46 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-06-13 18:34:46 +0000
commit1982929a0cdbd7060cd56f9e49f8474a7cce59c4 (patch)
tree9974bc8eca5cfaa79ce022791dfbab3b98cc93f5 /x11-misc/keytouch
parentVersion bump, fix tests being built unconditionally (bug #226355), add src_te... (diff)
downloadgentoo-2-1982929a0cdbd7060cd56f9e49f8474a7cce59c4.tar.gz
gentoo-2-1982929a0cdbd7060cd56f9e49f8474a7cce59c4.tar.bz2
gentoo-2-1982929a0cdbd7060cd56f9e49f8474a7cce59c4.zip
Version bump
(Portage version: 2.2_pre8/cvs/Linux 2.6.25.6 x86_64)
Diffstat (limited to 'x11-misc/keytouch')
-rw-r--r--x11-misc/keytouch/ChangeLog8
-rw-r--r--x11-misc/keytouch/files/keytouch-2.4.0-glibc28.patch44
-rw-r--r--x11-misc/keytouch/keytouch-2.4.0.ebuild92
3 files changed, 143 insertions, 1 deletions
diff --git a/x11-misc/keytouch/ChangeLog b/x11-misc/keytouch/ChangeLog
index a5f5702a4c6a..896414c68a63 100644
--- a/x11-misc/keytouch/ChangeLog
+++ b/x11-misc/keytouch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/keytouch
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.13 2008/02/29 20:49:48 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.14 2008/06/13 18:34:45 nyhm Exp $
+
+*keytouch-2.4.0 (13 Jun 2008)
+
+ 13 Jun 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/keytouch-2.4.0-glibc28.patch, +keytouch-2.4.0.ebuild:
+ Version bump
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> keytouch-2.3.2.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/x11-misc/keytouch/files/keytouch-2.4.0-glibc28.patch b/x11-misc/keytouch/files/keytouch-2.4.0-glibc28.patch
new file mode 100644
index 000000000000..1c1375869dce
--- /dev/null
+++ b/x11-misc/keytouch/files/keytouch-2.4.0-glibc28.patch
@@ -0,0 +1,44 @@
+--- keytouch-acpid/Makefile.am
++++ keytouch-acpid/Makefile.am
+@@ -3,7 +3,8 @@
+
+ AM_CPPFLAGS = -I. -I../string_to_keycode/ -I../mxml \
+ -DSYSCONF_DIR=\""$(sysconfdir)"\" \
+- -DPACKAGE_DATA_DIR=\""$(datadir)"\"
++ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
++ -D_GNU_SOURCE # struct ucred
+
+ AM_CFLAGS=@CFLAGS@ @X_CFLAGS@ -Wall
+
+--- keytouch-keyboard/src/check_syntax.c
++++ keytouch-keyboard/src/check_syntax.c
+@@ -29,10 +29,10 @@
+ You can contact me at: marvinr(at)users(dot)sf(dot)net
+ (replace (at) by @ and (dot) by .)
+ -----------------------------------------------------------------------------------*/
++#define _XOPEN_SOURCE /* strptime */
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+-#define _XOPEN_SOURCE /* glibc2 needs this */
+ #include <time.h>
+
+ #include <mxml.h>
+--- keytouch-keyboard/src/config.c
++++ keytouch-keyboard/src/config.c
+@@ -37,6 +37,7 @@
+ You can contact me at: marvinr(at)users(dot)sf(dot)net
+ (replace (at) by @ and (dot) by .)
+ -----------------------------------------------------------------------------------*/
++#define _GNU_SOURCE /* strptime, scandir */
+ #include <stdlib.h>
+ #include <dirent.h>
+ #include <dlfcn.h>
+@@ -45,7 +46,6 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdio.h>
+-#define _GNU_SOURCE /* glibc2 needs this */
+ #include <time.h>
+
+ #include <mxml.h>
diff --git a/x11-misc/keytouch/keytouch-2.4.0.ebuild b/x11-misc/keytouch/keytouch-2.4.0.ebuild
new file mode 100644
index 000000000000..5d7136fe6e58
--- /dev/null
+++ b/x11-misc/keytouch/keytouch-2.4.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/keytouch-2.4.0.ebuild,v 1.1 2008/06/13 18:34:45 nyhm Exp $
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Easily configure extra keyboard function keys"
+HOMEPAGE="http://keytouch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acpi kde"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libXtst
+ gnome-base/gnome-menus
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ acpi? ( sys-power/acpid )
+ kde? ( || (
+ kde-base/kdesu
+ kde-base/kdebase
+ ) )
+ !kde? ( x11-libs/gksu )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc28.patch
+ eautoreconf
+ sed -i \
+ 's/install-data-local//1' \
+ keytouch{-acpid,d,-init}/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ pushd ${d} > /dev/null
+ econf || die
+ emake || die "emake ${d} failed"
+ popd > /dev/null
+ done
+}
+
+src_install() {
+ if use acpi ; then
+ newinitd "${FILESDIR}"/${PN}-acpid ${PN} || die "newinitd failed"
+ else
+ doinitd "${FILESDIR}"/${PN} || die "doinitd failed"
+ fi
+
+ newicon keytouch-keyboard/pixmaps/icon.png ${PN}.png
+ make_desktop_entry ${PN} keyTouch ${PN} System
+
+ dodoc AUTHORS ChangeLog
+
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ emake -C ${d} DESTDIR="${D}" install \
+ || die "emake install ${d} failed"
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "To use keyTouch, add \"keytouchd\" to your"
+ elog "X startup programs and run"
+ elog "\"rc-update add keytouch default\""
+ elog
+ elog "If support for your keyboard is not included in"
+ elog "this release, check for new keyboard files at"
+ elog "${HOMEPAGE}dl-keyboards.html"
+ elog
+ elog "x11-misc/keytouch-editor can be used to create"
+ elog "your own keyboard files"
+ echo
+ if use acpi && ! linux_chkconfig_present INPUT_EVDEV ; then
+ ewarn "To add support for ACPI hotkeys, CONFIG_INPUT_EVDEV"
+ ewarn "must be enabled in your kernel config."
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " <*>/<M> Event interface"
+ echo
+ fi
+}