summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-10-28 01:31:52 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-10-28 01:31:52 +0000
commit81542089ba17b037d4b81888cf43fe81f671e569 (patch)
treef87272e30d36e7c8b27e60f20212bac2c7c8b279 /x11-misc/slim
parentVersion bump to 1.10.3 (diff)
downloadgentoo-2-81542089ba17b037d4b81888cf43fe81f671e569.tar.gz
gentoo-2-81542089ba17b037d4b81888cf43fe81f671e569.tar.bz2
gentoo-2-81542089ba17b037d4b81888cf43fe81f671e569.zip
fixed build system to not try and install slimlock if it wasnt built, bug 489610
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'x11-misc/slim')
-rw-r--r--x11-misc/slim/ChangeLog7
-rw-r--r--x11-misc/slim/files/slim-1.3.6-fix-slimlock-nopam.patch26
-rw-r--r--x11-misc/slim/slim-1.3.6-r3.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index fe599ef11f17..c7b33ec79347 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.127 2013/10/25 11:03:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.128 2013/10/28 01:31:52 axs Exp $
+
+ 28 Oct 2013; Ian Stakenvicius <axs@gentoo.org>
+ +files/slim-1.3.6-fix-slimlock-nopam.patch, slim-1.3.6-r3.ebuild:
+ fixed build system to not try and install slimlock if it wasnt built, bug
+ 489610
25 Oct 2013; Agostino Sarubbo <ago@gentoo.org> slim-1.3.5-r4.ebuild:
arm stable wrt bug #487688
diff --git a/x11-misc/slim/files/slim-1.3.6-fix-slimlock-nopam.patch b/x11-misc/slim/files/slim-1.3.6-fix-slimlock-nopam.patch
new file mode 100644
index 000000000000..bd6d1679c09e
--- /dev/null
+++ b/x11-misc/slim/files/slim-1.3.6-fix-slimlock-nopam.patch
@@ -0,0 +1,26 @@
+--- a/CMakeLists.txt 2013-10-27 21:24:21.193802669 -0400
++++ b/CMakeLists.txt 2013-10-27 21:26:54.127806951 -0400
+@@ -220,7 +220,6 @@
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES
+@@ -235,8 +234,14 @@
+
+ # man file
+ install(FILES slim.1 DESTINATION ${MANDIR}/man1/)
+-install(FILES slimlock.1 DESTINATION ${MANDIR}/man1/)
+ # configure
+ install(FILES slim.conf DESTINATION ${SYSCONFDIR})
++
++#slimlock
++if(BUILD_SLIMLOCK)
++install(TARGETS slimlock RUNTIME DESTINATION bin)
++install(FILES slimlock.1 DESTINATION ${MANDIR}/man1/)
++endif(BUILD_SLIMLOCK)
++
+ # themes directory
+ subdirs(themes)
diff --git a/x11-misc/slim/slim-1.3.6-r3.ebuild b/x11-misc/slim/slim-1.3.6-r3.ebuild
index d8b2343968e4..961cc49853c9 100644
--- a/x11-misc/slim/slim-1.3.6-r3.ebuild
+++ b/x11-misc/slim/slim-1.3.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.6-r3.ebuild,v 1.1 2013/10/24 18:55:57 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.6-r3.ebuild,v 1.2 2013/10/28 01:31:51 axs Exp $
EAPI=5
@@ -43,6 +43,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-strip-systemd-unit-install.patch
epatch "${FILESDIR}"/${P}-systemd-session.patch
epatch "${FILESDIR}"/${P}-session-chooser.patch
+ epatch "${FILESDIR}"/${P}-fix-slimlock-nopam.patch
if use elibc_FreeBSD; then
sed -i -e 's/"-DHAVE_SHADOW"/"-DNEEDS_BASENAME"/' CMakeLists.txt \