summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-09 11:13:44 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-09 11:13:44 +0000
commit0f43720ab7cf1e8c05be7ecd9f76fec466652380 (patch)
tree809022c48a2e5cafd3e0cfc70bd8906fa9447468 /x11-misc/wmakerconf
parentNew stat ebuild, closing bug #612 (diff)
downloadgentoo-2-0f43720ab7cf1e8c05be7ecd9f76fec466652380.tar.gz
gentoo-2-0f43720ab7cf1e8c05be7ecd9f76fec466652380.tar.bz2
gentoo-2-0f43720ab7cf1e8c05be7ecd9f76fec466652380.zip
initial ebuild, using SLOT technology ;o)
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.8.11
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.8.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1
new file mode 100644
index 000000000000..f3b723c38256
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1
@@ -0,0 +1 @@
+MD5 03749f08953638ed2a0ab260a407d264 wmakerconf-2.8.1.tar.gz 666175
diff --git a/x11-misc/wmakerconf/wmakerconf-2.8.1.ebuild b/x11-misc/wmakerconf/wmakerconf-2.8.1.ebuild
new file mode 100644
index 000000000000..d174b0d1fa17
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Joao Schim <joao@schim.net>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.8.1.ebuild,v 1.1 2002/02/09 11:13:44 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://wmaker.orcon.net.nz/current/${P}.tar.gz"
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0
+ x11-wm/WindowMaker
+ x11-libs/libPropList"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make prefix=${D}/usr install || die
+
+ dodoc README MANUAL AUTHORS TODO THANKS BUGS NEW COPYING ChangeLog
+}
+
+
+