summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-24 09:15:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-24 09:15:43 +0000
commit74176c5a439cd5ea09e924725410198c65edc924 (patch)
tree536de711b3171c32a119136ff94bcefe0df4b115 /x11-misc/xidle
parentRemoving old versions (diff)
downloadgentoo-2-74176c5a439cd5ea09e924725410198c65edc924.tar.gz
gentoo-2-74176c5a439cd5ea09e924725410198c65edc924.tar.bz2
gentoo-2-74176c5a439cd5ea09e924725410198c65edc924.zip
Die on build failure, die on dobin and doman failure, fix building with --as-needed.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-misc/xidle')
-rw-r--r--x11-misc/xidle/ChangeLog7
-rw-r--r--x11-misc/xidle/xidle-24102005.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/x11-misc/xidle/ChangeLog b/x11-misc/xidle/ChangeLog
index a3161101f39e..d8109e30dabc 100644
--- a/x11-misc/xidle/ChangeLog
+++ b/x11-misc/xidle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xidle
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xidle/ChangeLog,v 1.1 2008/11/12 06:57:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xidle/ChangeLog,v 1.2 2008/11/24 09:15:43 flameeyes Exp $
+
+ 24 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ xidle-24102005.ebuild:
+ Die on build failure, die on dobin and doman failure, fix building with
+ --as-needed.
*xidle-24102005 (12 Nov 2008)
diff --git a/x11-misc/xidle/xidle-24102005.ebuild b/x11-misc/xidle/xidle-24102005.ebuild
index e5e024ad3791..2283cec35ae8 100644
--- a/x11-misc/xidle/xidle-24102005.ebuild
+++ b/x11-misc/xidle/xidle-24102005.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xidle/xidle-24102005.ebuild,v 1.1 2008/11/12 06:57:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xidle/xidle-24102005.ebuild,v 1.2 2008/11/24 09:15:43 flameeyes Exp $
inherit eutils toolchain-funcs
@@ -30,12 +30,12 @@ src_unpack() {
src_compile() {
local my_libs="-lXss -lXext -lX11"
local my_compile
- my_compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} ${my_libs} -o ${PN}{,.c}"
+ my_compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN}{,.c} ${my_libs}"
echo ${my_compile}
- eval ${my_compile}
+ eval ${my_compile} || die "compile failed"
}
src_install() {
- dobin ${PN}
- doman ${PN}.1
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1 || die "doman failed"
}