summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2009-04-17 19:07:32 +0000
committerSven Wegener <swegener@gentoo.org>2009-04-17 19:07:32 +0000
commit2db4ce4e57496620e85c4297e5eb92c38b35403e (patch)
treebeeb28e15269bae65eca434419ff8d3462690788 /x11-misc
parentMarking 1.3, 1.4, 1.6 ~ppc for bug 265361 (diff)
downloadgentoo-2-2db4ce4e57496620e85c4297e5eb92c38b35403e.tar.gz
gentoo-2-2db4ce4e57496620e85c4297e5eb92c38b35403e.tar.bz2
gentoo-2-2db4ce4e57496620e85c4297e5eb92c38b35403e.zip
Print a warning when non-native avahi support has been enabled, bug #253218.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.6.ebuild10
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.7.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 292f3b2875c8..4f68a70b0a9c 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.68 2009/04/17 18:49:17 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.69 2009/04/17 19:07:32 swegener Exp $
+
+ 17 Apr 2009; Sven Wegener <swegener@gentoo.org> x11vnc-0.9.6,
+ x11vnc-0.9.7:
+ Print a warning when non-native avahi support has been enabled, bug
+ #253218.
*x11vnc-0.9.7 (17 Apr 2009)
diff --git a/x11-misc/x11vnc/x11vnc-0.9.6.ebuild b/x11-misc/x11vnc/x11vnc-0.9.6.ebuild
index 21f9f297337d..fc02930a1f05 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.6.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.6.ebuild,v 1.6 2009/03/02 16:06:44 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.6.ebuild,v 1.7 2009/04/17 19:07:32 swegener Exp $
DESCRIPTION="A VNC server for real X displays"
HOMEPAGE="http://www.karlrunge.com/x11vnc/"
@@ -33,6 +33,14 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
+pkg_setup() {
+ if use avahi && ! use threads && ! use system-libvncserver
+ then
+ ewarn "Non-native avahi support has been enabled."
+ ewarn "Native avahi support can be enabled by also enabling the threads USE flag."
+ fi
+}
+
src_compile() {
local myconf=""
diff --git a/x11-misc/x11vnc/x11vnc-0.9.7.ebuild b/x11-misc/x11vnc/x11vnc-0.9.7.ebuild
index 6ee478cf846e..279fdce7413a 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.7.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.7.ebuild,v 1.1 2009/04/17 18:49:17 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.7.ebuild,v 1.2 2009/04/17 19:07:32 swegener Exp $
EAPI="2"
@@ -35,6 +35,14 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
+pkg_setup() {
+ if use avahi && ! use threads && ! use system-libvncserver
+ then
+ ewarn "Non-native avahi support has been enabled."
+ ewarn "Native avahi support can be enabled by also enabling the threads USE flag."
+ fi
+}
+
src_configure() {
local myconf=""