summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2011-06-26 13:07:04 +0000
committerTristan Heaven <nyhm@gentoo.org>2011-06-26 13:07:04 +0000
commitd7bd410ba32af3293d6bb3696c5dec063d063520 (patch)
tree58c5f891734027e089df9d348b5fac5fc4987f26 /x11-misc
parentMarking lame-3.98.4 ppc for bug 365273 (diff)
downloadgentoo-2-d7bd410ba32af3293d6bb3696c5dec063d063520.tar.gz
gentoo-2-d7bd410ba32af3293d6bb3696c5dec063d063520.tar.bz2
gentoo-2-d7bd410ba32af3293d6bb3696c5dec063d063520.zip
Add applet USE flag
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/revelation/ChangeLog8
-rw-r--r--x11-misc/revelation/files/revelation-0.4.11-build.patch68
-rw-r--r--x11-misc/revelation/metadata.xml3
-rw-r--r--x11-misc/revelation/revelation-0.4.11-r2.ebuild13
4 files changed, 83 insertions, 9 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index af2ebdb4a277..67158dedd5cc 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/revelation
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.18 2010/05/28 18:00:57 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.19 2011/06/26 13:07:04 nyhm Exp $
+
+ 26 Jun 2011; Tristan Heaven <nyhm@gentoo.org> revelation-0.4.11-r2.ebuild,
+ files/revelation-0.4.11-build.patch, metadata.xml:
+ Add applet USE flag
28 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
revelation-0.4.11-r2.ebuild:
diff --git a/x11-misc/revelation/files/revelation-0.4.11-build.patch b/x11-misc/revelation/files/revelation-0.4.11-build.patch
index e699034ad84d..b5c67e42aa6d 100644
--- a/x11-misc/revelation/files/revelation-0.4.11-build.patch
+++ b/x11-misc/revelation/files/revelation-0.4.11-build.patch
@@ -18,6 +18,73 @@
RVL_PYTHON_PATH(2.3)
RVL_PYGTK()
+@@ -26,11 +27,17 @@
+ RVL_PYTHON_MODULE(gconf, yes)
+ RVL_PYTHON_MODULE(gtk, yes)
+ RVL_PYTHON_MODULE(gnome, yes)
+-RVL_PYTHON_MODULE(gnomeapplet, yes)
+ RVL_PYTHON_MODULE(gnomevfs, yes)
+ RVL_PYTHON_MODULE(gobject, yes)
+ RVL_PYTHON_MODULE(pango, yes)
+
++AC_ARG_ENABLE([applet],
++ [AS_HELP_STRING([--enable-applet], [install the panel applet])],
++ [enable_applet="${enableval}"], [enable_applet="no"])
++AM_CONDITIONAL([ENABLE_APPLET], [test "${enable_applet}" = "yes"])
++if test "${enable_applet}" = "yes" ; then
++ RVL_PYTHON_MODULE([gnomeapplet], [yes])
++fi
+
+ dnl output files
+ AC_OUTPUT([
+--- data/bonobo/Makefile.am
++++ data/bonobo/Makefile.am
+@@ -6,10 +6,13 @@
+ #
+
+ serverdir = $(libdir)/bonobo/servers
+-server_DATA = GNOME_RevelationApplet.server
+ CLEANFILES = GNOME_RevelationApplet.server
+ EXTRA_DIST = GNOME_RevelationApplet.server.in
+
++if ENABLE_APPLET
++server_DATA = GNOME_RevelationApplet.server
++endif
++
+ GNOME_RevelationApplet.server: GNOME_RevelationApplet.server.in
+ sed \
+ -e "s|\@libexecdir\@|$(libexecdir)|" \
+--- data/gconf/Makefile.am
++++ data/gconf/Makefile.am
+@@ -6,7 +6,11 @@
+ #
+
+ schemadir = @GCONF_SCHEMA_FILE_DIR@
+-dist_schema_DATA = revelation.schemas revelation-applet.schemas
++dist_schema_DATA = revelation.schemas
++
++if ENABLE_APPLET
++dist_schema_DATA += revelation-applet.schemas
++endif
+
+
+ install-data-hook:
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -7,10 +7,12 @@
+
+ SUBDIRS = bundle lib wrap
+ bin_SCRIPTS = revelation
+-libexec_SCRIPTS = revelation-applet
+ EXTRA_DIST = revelation.in revelation-applet.in
+ CLEANFILES = revelation revelation-applet
+
++if ENABLE_APPLET
++libexec_SCRIPTS = revelation-applet
++endif
+
+ revelation: revelation.in
+ sed \
--- src/wrap/crack/crack.c
+++ src/wrap/crack/crack.c
@@ -24,8 +24,6 @@
@@ -32,7 +99,6 @@
--- src/wrap/crack/Makefile.am
+++ src/wrap/crack/Makefile.am
@@ -5,19 +5,9 @@
- # $Id: revelation-0.4.11-build.patch,v 1.2 2010/01/07 20:30:17 nyhm Exp $
#
-module_PROGRAMS = crack.so
diff --git a/x11-misc/revelation/metadata.xml b/x11-misc/revelation/metadata.xml
index dc05e68c4faa..b6a43cbd572c 100644
--- a/x11-misc/revelation/metadata.xml
+++ b/x11-misc/revelation/metadata.xml
@@ -6,4 +6,7 @@
<email>nyhm@gentoo.org</email>
<name>Tristan Heaven</name>
</maintainer>
+ <use>
+ <flag name="applet">Enable applet for <pkg>gnome-base/gnome-panel</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/x11-misc/revelation/revelation-0.4.11-r2.ebuild b/x11-misc/revelation/revelation-0.4.11-r2.ebuild
index 80c2e82f1dbd..944eac20de65 100644
--- a/x11-misc/revelation/revelation-0.4.11-r2.ebuild
+++ b/x11-misc/revelation/revelation-0.4.11-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.11-r2.ebuild,v 1.7 2010/05/28 18:00:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.11-r2.ebuild,v 1.8 2011/06/26 13:07:04 nyhm Exp $
inherit autotools eutils multilib python gnome2
@@ -11,17 +11,17 @@ SRC_URI="ftp://oss.codepoet.no/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="applet"
RESTRICT="test"
DEPEND="dev-python/pygtk
dev-python/pycrypto
- dev-python/gnome-applets-python
dev-python/gconf-python
dev-python/gnome-vfs-python
dev-python/libbonobo-python
dev-python/libgnome-python
- sys-libs/cracklib"
+ sys-libs/cracklib
+ applet? ( dev-python/gnome-applets-python )"
RDEPEND="${DEPEND}"
src_unpack() {
@@ -37,7 +37,8 @@ src_compile() {
gnome2_src_compile \
--disable-dependency-tracking \
--disable-desktop-update \
- --disable-mime-update
+ --disable-mime-update \
+ $(use_enable applet)
}
src_install() {