summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-02-02 16:33:13 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-02-02 16:33:13 +0000
commit08219c1dad8951b8bef4139a62f02fd309bff7ff (patch)
tree36594b1e3d61fffac6bb43c16e84c915d1c63779 /x11-plugins/wmmsens/wmmsens-0.29.6.ebuild
parentFixed DEPEND for modular X. (diff)
downloadgentoo-2-08219c1dad8951b8bef4139a62f02fd309bff7ff.tar.gz
gentoo-2-08219c1dad8951b8bef4139a62f02fd309bff7ff.tar.bz2
gentoo-2-08219c1dad8951b8bef4139a62f02fd309bff7ff.zip
Fixed DEPEND for modular X.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-plugins/wmmsens/wmmsens-0.29.6.ebuild')
-rw-r--r--x11-plugins/wmmsens/wmmsens-0.29.6.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild b/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild
index 5e9c51d2aa0d..90da02440606 100644
--- a/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild
+++ b/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild,v 1.4 2005/11/11 09:34:27 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/wmmsens-0.29.6.ebuild,v 1.5 2006/02/02 16:30:52 nelchael Exp $
inherit eutils
@@ -11,9 +11,17 @@ SRC_URI="http://www.digressed.net/wmmsens/src//${P/_/-}.tar.gz"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="x86 ~amd64"
-DEPEND="virtual/x11"
IUSE=""
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )
+ sys-apps/lm_sensors"
+
src_compile() {
cd src
# remove depends at end of Makefile that cause problems