summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:51:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:51:26 +0000
commit07014941ecd9e47688d82960f71cad0986b7f968 (patch)
treea957fd312d53a03a31d2f5a7516f64679f4fd2ec /x11-plugins
parentUse EAPI5 instead of EAPI1. (diff)
downloadgentoo-2-07014941ecd9e47688d82960f71cad0986b7f968.tar.gz
gentoo-2-07014941ecd9e47688d82960f71cad0986b7f968.tar.bz2
gentoo-2-07014941ecd9e47688d82960f71cad0986b7f968.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/matchbox-applet-volume/ChangeLog9
-rw-r--r--x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild30
2 files changed, 16 insertions, 23 deletions
diff --git a/x11-plugins/matchbox-applet-volume/ChangeLog b/x11-plugins/matchbox-applet-volume/ChangeLog
index 10dfff751cf5..6f999057d729 100644
--- a/x11-plugins/matchbox-applet-volume/ChangeLog
+++ b/x11-plugins/matchbox-applet-volume/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/matchbox-applet-volume
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-volume/ChangeLog,v 1.13 2012/06/04 00:36:04 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-volume/ChangeLog,v 1.14 2014/04/07 19:51:26 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org>
+ matchbox-applet-volume-0.1.ebuild:
+ Use EAPI5 instead of EAPI1.
04 Jun 2012; Michael Weber <xmw@gentoo.org> matchbox-applet-volume-0.1.ebuild:
ppc stable (bug 309407)
@@ -52,4 +56,3 @@
+matchbox-applet-volume-0.1.ebuild:
- Initial import. Original ebuild by Priit Laes, modifications by Björn
Ruberg and Yuri Vasilevski.
-
diff --git a/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild b/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
index 32b44f8b2b01..b50fed17190c 100644
--- a/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
+++ b/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild,v 1.11 2012/06/04 00:36:04 xmw Exp $
-
-EAPI=1
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild,v 1.12 2014/04/07 19:51:26 ssuominen Exp $
+EAPI=5
inherit versionator
MY_PN=${PN/matchbox/mb}
@@ -12,28 +11,19 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Matchbox panel tray app for controlling volume levels."
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ~arm ~hppa ppc x86"
IUSE=""
-DEPEND=">=x11-libs/libmatchbox-1.5
+COMMON_DEPEND=">=x11-libs/libmatchbox-1.5
x11-libs/gtk+:2"
-
-RDEPEND="${DEPEND}
+RDEPEND="${COMMON_DEPEND}
x11-wm/matchbox-panel"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- econf || die "Configuration failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
+S=${WORKDIR}/${MY_P}
- dodoc AUTHORS ChangeLog INSTALL NEWS README
-}
+DOCS="AUTHORS ChangeLog NEWS README"