summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-03-30 22:12:51 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-03-30 22:12:51 +0000
commitbc7e27cdbdb3673be950d40a70cef569d932df51 (patch)
treeac36b2db03c7c0f17fb95fe4b772321cce78fecc /x11-terms/rxvt-unicode
parentMark 1.3 ~ia64 (diff)
downloadgentoo-2-bc7e27cdbdb3673be950d40a70cef569d932df51.tar.gz
gentoo-2-bc7e27cdbdb3673be950d40a70cef569d932df51.tar.bz2
gentoo-2-bc7e27cdbdb3673be950d40a70cef569d932df51.zip
Version bump.
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.73
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-7.7.ebuild80
3 files changed, 89 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 2e246a1db806..3b9dda2298ed 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.69 2006/02/21 11:03:20 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.70 2006/03/30 22:12:51 exg Exp $
+
+*rxvt-unicode-7.7 (30 Mar 2006)
+
+ 30 Mar 2006; Emanuele Giaquinta <exg@gentoo.org> +rxvt-unicode-7.7.ebuild:
+ Version bump. Xft support is now optional.
21 Feb 2006; Michele Noberasco <s4t4n@gentoo.org> rxvt-unicode-5.3.ebuild,
rxvt-unicode-5.1.ebuild,rxvt-unicode-4.0.ebuild,rxvt-unicode-3.0.ebuild,:
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7
new file mode 100644
index 000000000000..6cf357c57ea8
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7
@@ -0,0 +1,3 @@
+MD5 68298390375da1b34f89a0aa634c9b20 rxvt-unicode-7.7.tar.bz2 876369
+RMD160 6dd55a7a71207e774239ca0c362ae35d2dc88237 rxvt-unicode-7.7.tar.bz2 876369
+SHA256 04ecd2577ee0c210df610b4a5d870f2bda57c80962fb5b51ae9c4a94098c726c rxvt-unicode-7.7.tar.bz2 876369
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-7.7.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-7.7.ebuild
new file mode 100644
index 000000000000..09f5d5d8a452
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-7.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-7.7.ebuild,v 1.1 2006/03/30 22:12:51 exg Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="truetype perl"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ dev-lang/perl
+ perl? ( sys-devel/libperl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/libtool
+ || (
+ (
+ x11-proto/xproto
+ x11-libs/libXt
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ sed -i -e \
+ "s:-g -O3:${CXXFLAGS}:" \
+ configure
+}
+
+src_compile() {
+ econf \
+ --enable-everything \
+ $(use_enable xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ --disable-iso14755 \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+