summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-09 16:22:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-09 16:22:27 +0000
commit3181783c2b3099372696bb97b4ced1004aae61c9 (patch)
tree05dd94be7150e83692967603a4c9f578f0f7342c /x11-terms/xterm
parentdev-lang/tcl: Fix build system so that autoconf will always be executed and s... (diff)
downloadgentoo-2-3181783c2b3099372696bb97b4ced1004aae61c9.tar.gz
gentoo-2-3181783c2b3099372696bb97b4ced1004aae61c9.tar.bz2
gentoo-2-3181783c2b3099372696bb97b4ced1004aae61c9.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-terms/xterm')
-rw-r--r--x11-terms/xterm/ChangeLog7
-rw-r--r--x11-terms/xterm/xterm-288.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index f32408289572..cd55482ea311 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/xterm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.376 2013/01/04 18:04:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.377 2013/01/09 16:22:27 ssuominen Exp $
+
+*xterm-288 (09 Jan 2013)
+
+ 09 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +xterm-288.ebuild:
+ Version bump.
04 Jan 2013; Jeroen Roovers <jer@gentoo.org> xterm-285.ebuild:
Stable for HPPA (bug #440872).
diff --git a/x11-terms/xterm/xterm-288.ebuild b/x11-terms/xterm/xterm-288.ebuild
new file mode 100644
index 000000000000..79881ee12862
--- /dev/null
+++ b/x11-terms/xterm/xterm-288.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-288.ebuild,v 1.1 2013/01/09 16:22:27 ssuominen Exp $
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="toolbar truetype unicode Xaw3d"
+
+COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ >=sys-libs/ncurses-5.7-r7
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/kbproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/etc \
+ --disable-full-tgetent \
+ --with-app-defaults="${DEFAULTS_DIR}" \
+ --disable-setuid \
+ --disable-setgid \
+ --with-utempter \
+ --with-x \
+ $(use_with Xaw3d) \
+ --disable-imake \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-exec-xterm \
+ $(use_enable truetype freetype) \
+ --enable-i18n \
+ --enable-load-vt-fonts \
+ --enable-logging \
+ $(use_enable toolbar) \
+ $(use_enable unicode mini-luit) \
+ $(use_enable unicode luit) \
+ --enable-wide-chars \
+ --enable-dabbrev \
+ --enable-warnings
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README{,.i18n} ctlseqs.txt
+ dohtml xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e "s:blue2$:blue:" "${ED}${DEFAULTS_DIR}"/XTerm-color
+}