summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-24 17:20:56 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-24 17:20:56 +0000
commit268740fb00cf4a17b85aef957db1c0c000d79f94 (patch)
tree4e0192c1ad6341681772081bdf33a2b1b3f6784e /x11-themes/gtk-engines-rezlooks
parentmarked x86 per bug 427894 (diff)
downloadgentoo-2-268740fb00cf4a17b85aef957db1c0c000d79f94.tar.gz
gentoo-2-268740fb00cf4a17b85aef957db1c0c000d79f94.tar.bz2
gentoo-2-268740fb00cf4a17b85aef957db1c0c000d79f94.zip
Let it compile against glib-2.32, drop .la files.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines-rezlooks')
-rw-r--r--x11-themes/gtk-engines-rezlooks/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch13
-rw-r--r--x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild12
3 files changed, 26 insertions, 7 deletions
diff --git a/x11-themes/gtk-engines-rezlooks/ChangeLog b/x11-themes/gtk-engines-rezlooks/ChangeLog
index b1635b17a0a2..e68a7e5bf1db 100644
--- a/x11-themes/gtk-engines-rezlooks/ChangeLog
+++ b/x11-themes/gtk-engines-rezlooks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gtk-engines-rezlooks
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-rezlooks/ChangeLog,v 1.9 2012/05/05 04:10:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-rezlooks/ChangeLog,v 1.10 2012/07/24 17:20:56 pacho Exp $
+
+ 24 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gtk-engines-rezlooks-0.6-glib-single-include.patch,
+ gtk-engines-rezlooks-0.6.ebuild:
+ Let it compile against glib-2.32, drop .la files.
05 May 2012; Jeff Horelick <jdhore@gentoo.org>
gtk-engines-rezlooks-0.6.ebuild:
@@ -38,4 +43,3 @@
11 Feb 2007; Saleem Abdulrasool <compnerd@gentoo.org> +metadata.xml,
+gtk-engines-rezlooks-0.6.ebuild:
Intial import of the rezlooks engine
-
diff --git a/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch b/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch
new file mode 100644
index 000000000000..340bd046fb0e
--- /dev/null
+++ b/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch
@@ -0,0 +1,13 @@
+Index: rezlooks-0.6/src/animation.c
+===================================================================
+--- rezlooks-0.6.orig/src/animation.c
++++ rezlooks-0.6/src/animation.c
+@@ -7,7 +7,7 @@
+ #include "animation.h"
+
+ #ifdef HAVE_ANIMATION
+-#include <glib/gtimer.h>
++#include <glib.h>
+
+ struct _AnimationInfo {
+ GTimer *timer;
diff --git a/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild
index b45f694d99a9..6d867153459f 100644
--- a/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild
+++ b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild,v 1.9 2012/05/05 04:10:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6.ebuild,v 1.10 2012/07/24 17:20:56 pacho Exp $
-EAPI=3
-inherit autotools
+EAPI=4
+inherit autotools eutils
DESCRIPTION="Rezlooks GTK+ Engine"
HOMEPAGE="http://www.gnome-look.org/content/show.php?content=39179"
@@ -26,6 +26,8 @@ src_prepare() {
mv Changelog{,.1}
mv Changelog.1 ChangeLog
+ epatch "${FILESDIR}/${PN}-0.6-glib-single-include.patch"
+
eautoreconf # required for interix
}
@@ -34,6 +36,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog CREDITS NEWS README
+ default
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
}