summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-04 21:53:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-04 21:53:43 +0000
commitc939c9438cec4dd4dd6fd33ad57a2bc92429fc1c (patch)
treea9dcf2488aceea614b1f6e33cd8d597ac7456126 /x11-wm/compiz
parentRevision bump to fix bug 335682 (diff)
downloadgentoo-2-c939c9438cec4dd4dd6fd33ad57a2bc92429fc1c.tar.gz
gentoo-2-c939c9438cec4dd4dd6fd33ad57a2bc92429fc1c.tar.bz2
gentoo-2-c939c9438cec4dd4dd6fd33ad57a2bc92429fc1c.zip
Helping out a bit: disable static libraries (they are not linked against, are most plugins) and .la files (same reasoning); add a gconf USE flag because even if you want GNOME integration you might not want to pay the GConf toll (lots of schemas) and rather prefer flat files. Wire the svg USE flag to librsvg.
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/compiz')
-rw-r--r--x11-wm/compiz/ChangeLog12
-rw-r--r--x11-wm/compiz/compiz-0.8.6-r1.ebuild159
-rw-r--r--x11-wm/compiz/metadata.xml22
3 files changed, 185 insertions, 8 deletions
diff --git a/x11-wm/compiz/ChangeLog b/x11-wm/compiz/ChangeLog
index 01cbed3188b4..fdf6be9660fe 100644
--- a/x11-wm/compiz/ChangeLog
+++ b/x11-wm/compiz/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-wm/compiz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.53 2010/04/03 06:03:27 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.54 2010/09/04 21:53:43 flameeyes Exp $
+
+*compiz-0.8.6-r1 (04 Sep 2010)
+
+ 04 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +compiz-0.8.6-r1.ebuild, metadata.xml:
+ Helping out a bit: disable static libraries (they are not linked against,
+ are most plugins) and .la files (same reasoning); add a gconf USE flag
+ because even if you want GNOME integration you might not want to pay the
+ GConf toll (lots of schemas) and rather prefer flat files. Wire the svg
+ USE flag to librsvg.
*compiz-0.8.6 (03 Apr 2010)
*compiz-0.8.4-r3 (03 Apr 2010)
diff --git a/x11-wm/compiz/compiz-0.8.6-r1.ebuild b/x11-wm/compiz/compiz-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..77ecd67c66fe
--- /dev/null
+++ b/x11-wm/compiz/compiz-0.8.6-r1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.8.6-r1.ebuild,v 1.1 2010/09/04 21:53:43 flameeyes Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="OpenGL window and compositing manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+cairo dbus fuse gnome gconf gtk kde +svg"
+
+COMMONDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ media-libs/libpng
+ >=media-libs/mesa-6.5.1-r1
+ >=x11-base/xorg-server-1.1.1-r1
+ x11-libs/libX11[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libXrender-0.8.4
+ >=x11-libs/startup-notification-0.7
+ cairo? (
+ x11-libs/cairo[X]
+ )
+ dbus? ( >=sys-apps/dbus-1.0 )
+ fuse? ( sys-fs/fuse )
+ gnome? (
+ >=gnome-base/gnome-control-center-2.16.1:2
+ gnome-base/gnome-desktop
+ gconf? ( gnome-base/gconf:2 )
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.8.0:2
+ >=x11-libs/libwnck-2.18.3
+ x11-libs/pango
+ )
+ kde? (
+ || (
+ >=kde-base/kwin-4.2.0
+ kde-base/kwin:live
+ )
+ )
+ svg? (
+ >=gnome-base/librsvg-2.14.0:2
+ >=x11-libs/cairo-1.0
+ )
+"
+
+DEPEND="${COMMONDEPEND}
+ dev-util/pkgconfig
+ x11-proto/damageproto
+ x11-proto/xineramaproto
+"
+
+RDEPEND="${COMMONDEPEND}
+ x11-apps/mesa-progs
+ x11-apps/xvinfo
+"
+
+src_prepare() {
+
+ echo "gtk/gnome/compiz-wm.desktop.in" >> "${S}/po/POTFILES.skip"
+ echo "metadata/core.xml.in" >> "${S}/po/POTFILES.skip"
+
+ if ! use gnome || ! use gconf; then
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ # We make gconf optional by itself, but only if gnome is also
+ # enabled, otherwise we simply disable it.
+ if use gnome; then
+ myconf="${myconf} $(use_enable gconf)"
+ else
+ myconf="${myconf} --disable-gconf"
+ fi
+
+ econf --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ --disable-gnome-keybindings \
+ --with-default-plugins \
+ $(use_enable svg librsvg) \
+ $(use_enable cairo annotate) \
+ $(use_enable dbus) \
+ $(use_enable dbus dbus-glib) \
+ $(use_enable fuse) \
+ $(use_enable gnome) \
+ $(use_enable gnome metacity) \
+ $(use_enable gtk) \
+ $(use_enable kde kde4) \
+ --disable-kde \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ find "${D}" -name '*.la' -delete || die
+
+ # Install compiz-manager
+ dobin "${FILESDIR}/compiz-manager" || die "dobin failed"
+
+ # Add the full-path to lspci
+ sed -i "s#lspci#/usr/sbin/lspci#" "${D}/usr/bin/compiz-manager" || die "sed 1 failed"
+
+ # Fix the hardcoded lib paths
+ sed -i "s#/lib/#/$(get_libdir)/#g" "${D}/usr/bin/compiz-manager" || die "sed 2 failed"
+
+ # Create gentoo's config file
+ dodir /etc/xdg/compiz || die "dodir failed"
+
+ cat <<- EOF > "${D}/etc/xdg/compiz/compiz-manager"
+ COMPIZ_BIN_PATH="/usr/bin/"
+ PLUGIN_PATH="/usr/$(get_libdir)/compiz/"
+ LIBGL_NVIDIA="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ LIBGL_FGLRX="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ KWIN="$(type -p kwin)"
+ METACITY="$(type -p metacity)"
+ SKIP_CHECKS="yes"
+ EOF
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ insinto "/usr/share/applications"
+ doins "${FILESDIR}/compiz.desktop" || die "Failed to install compiz.desktop"
+}
+
+pkg_preinst() {
+ use gnome && use gconf && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gnome && use gconf && gnome2_gconf_install
+
+ ewarn "If you update to x11-wm/metacity-2.24 after you install ${P},"
+ ewarn "gtk-window-decorator will crash until you reinstall ${PN} again."
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
diff --git a/x11-wm/compiz/metadata.xml b/x11-wm/compiz/metadata.xml
index 7c340e5056be..da65f877f7a0 100644
--- a/x11-wm/compiz/metadata.xml
+++ b/x11-wm/compiz/metadata.xml
@@ -1,11 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<use>
- <flag name="fuse">Enables support for the filesystem in userspace plugin through <pkg>sys-fs/fuse</pkg>.</flag>
-</use>
-<herd>desktop-effects</herd>
-<longdescription>
-compiz is a compositing window manager that uses 3D graphics acceleration via OpenGL.
-</longdescription>
+ <use>
+ <flag name="fuse">
+ Enables support for the filesystem in userspace plugin through <pkg>sys-fs/fuse</pkg>.
+ </flag>
+ <flag name="gconf">
+ Enable the GConf-based configuration backend; it is not required
+ to work with GNOME, and might actually be faster if it's not
+ used.
+ </flag>
+ </use>
+
+ <herd>desktop-effects</herd>
+ <longdescription>
+ compiz is a compositing window manager that uses 3D graphics acceleration via OpenGL.
+ </longdescription>
</pkgmetadata>