summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-14 20:26:25 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-14 20:26:25 +0000
commitfead47344a6249109e7214119036800c15200c39 (patch)
treed9ab41d51b0a47d0257a58602e6a17a8c6af3379 /x11-wm/windowmaker
parentDrop function rename (fixed in official WindowMaker) (diff)
downloadgentoo-2-fead47344a6249109e7214119036800c15200c39.tar.gz
gentoo-2-fead47344a6249109e7214119036800c15200c39.tar.bz2
gentoo-2-fead47344a6249109e7214119036800c15200c39.zip
Version bump, with official tarball now
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/ChangeLog8
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.2.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/x11-wm/windowmaker/ChangeLog b/x11-wm/windowmaker/ChangeLog
index cdde80b7b53b..a1491741210b 100644
--- a/x11-wm/windowmaker/ChangeLog
+++ b/x11-wm/windowmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/windowmaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.130 2012/02/10 18:20:06 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.131 2012/02/14 20:26:25 voyageur Exp $
+
+*windowmaker-0.95.2 (14 Feb 2012)
+
+ 14 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +windowmaker-0.95.2.ebuild:
+ Version bump, with official tarball now
*windowmaker-0.95.1 (10 Feb 2012)
diff --git a/x11-wm/windowmaker/windowmaker-0.95.2.ebuild b/x11-wm/windowmaker/windowmaker-0.95.2.ebuild
new file mode 100644
index 000000000000..a966ceb4996b
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-0.95.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.95.2.ebuild,v 1.1 2012/02/14 20:26:25 voyageur Exp $
+
+EAPI=4
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="http://www.windowmaker.org/"
+SRC_URI=" http://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
+ http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif jpeg nls png tiff modelock xinerama +xrandr"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ png? ( media-libs/libpng:0 )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff:0 )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}
+ nls? ( >=sys-devel/gettext-0.10.39 )"
+
+S=${WORKDIR}/${P/windowm/WindowM}
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
+ sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ fi;
+ done;
+}
+
+src_configure() {
+ local myconf
+
+ # image format types
+ # xpm is provided by X itself
+ myconf="--enable-xpm $(use_enable png) $(use_enable jpeg) $(use_enable gif) $(use_enable tiff)"
+
+ # non required X capabilities
+ myconf="${myconf} $(use_enable modelock) $(use_enable xrandr) $(use_enable xinerama)"
+
+ if use nls; then
+ [[ -z $LINGUAS ]] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ else
+ myconf="${myconf} --disable-locale"
+ fi
+
+ # default settings with $myconf appended
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --with-x \
+ --enable-usermenu \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --with-nlsdir="${EPREFIX}"/usr/share/locale \
+ ${myconf}
+
+ cd ../WindowMaker-extra-0.1
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ cd ../WindowMaker-extra-0.1
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
+ README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ emake DESTDIR="${D}" install
+
+ newdoc README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+}