summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnustep-libs/sqlclient/ChangeLog10
-rw-r--r--gnustep-libs/sqlclient/metadata.xml8
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild46
3 files changed, 64 insertions, 0 deletions
diff --git a/gnustep-libs/sqlclient/ChangeLog b/gnustep-libs/sqlclient/ChangeLog
new file mode 100644
index 000000000000..90d02e81f9b5
--- /dev/null
+++ b/gnustep-libs/sqlclient/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-libs/sqlclient
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/sqlclient/ChangeLog,v 1.1 2014/01/30 00:07:03 voyageur Exp $
+
+*sqlclient-1.7.0 (30 Jan 2014)
+
+ 30 Jan 2014; Bernard Cafarelli <voyageur@gentoo.org> +sqlclient-1.7.0.ebuild,
+ +metadata.xml:
+ Initial commit, ebuild by adr in bug #480620
+
diff --git a/gnustep-libs/sqlclient/metadata.xml b/gnustep-libs/sqlclient/metadata.xml
new file mode 100644
index 000000000000..530936af7529
--- /dev/null
+++ b/gnustep-libs/sqlclient/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>The SQLClient library is designed to provide a simple interface to SQL databases for GNUstep applications. It does not attempt the sort of abstraction provided by the much more sophisticated GDL2 library but rather allows applications to directly execute SQL queries and statements.
+
+SQLClient provides for the Objective-C programmer much the same thing that JDBC provides for the Java programmer (though SQLClient is a bit faster, easier to use, and easier to add new database backends for than JDBC).</longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild b/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild
new file mode 100644
index 000000000000..36a6bc452abd
--- /dev/null
+++ b/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild,v 1.1 2014/01/30 00:07:03 voyageur Exp $
+
+EAPI=5
+inherit java-pkg-opt-2 gnustep-2
+
+MY_P=${P/sqlc/SQLC}
+DESCRIPTION="GNUstep lightweight database abstraction layer"
+HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="java mysql postgres +sqlite"
+
+RDEPEND=">=gnustep-libs/performance-0.3.2
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( >=dev-db/sqlite-3 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( java mysql postgres sqlite )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+}
+
+src_configure() {
+ local myconf=""
+ use java || myconf="${myconf} --disable-jdbc-bundle"
+ use mysql || myconf="${myconf} --disable-mysql-bundle"
+ use postgres || myconf="${myconf} --disable-postgres-bundle"
+ use sqlite || myconf="${myconf} --disable-sqllite-bundle"
+
+ egnustep_env
+ econf ${myconf}
+}