summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/latex2html/latex2html-2002.2.ebuild16
-rw-r--r--app-text/mgv/mgv-3.1.5.ebuild18
-rw-r--r--app-text/mlview/mlview-0.0.3_rc1.ebuild16
3 files changed, 18 insertions, 32 deletions
diff --git a/app-text/latex2html/latex2html-2002.2.ebuild b/app-text/latex2html/latex2html-2002.2.ebuild
index 33ccddb61205..01ae0792f7d0 100644
--- a/app-text/latex2html/latex2html-2002.2.ebuild
+++ b/app-text/latex2html/latex2html-2002.2.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/latex2html/latex2html-2002.2.ebuild,v 1.2 2002/12/09 04:17:44 manson Exp $
-
-IUSE="gif png"
+# $Header: /var/cvsroot/gentoo-x86/app-text/latex2html/latex2html-2002.2.ebuild,v 1.3 2002/12/18 15:51:16 vapier Exp $
MY_P=${P/./-}
S=${WORKDIR}/${MY_P}
DESCRIPTION="LATEX2HTML is a convertor written in Perl that converts LATEX documents to HTML."
SRC_URI="http://saftsack.fs.uni-bayreuth.de/~latex2ht/current/${MY_P}.tar.gz"
-HOMEPAGE="http://www.latex2html.org"
+HOMEPAGE="http://www.latex2html.org/"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
+IUSE="gif png"
DEPEND="sys-apps/supersed"
-
RDEPEND="app-text/ghostscript
app-text/tetex
media-libs/netpbm
@@ -25,7 +23,6 @@ RDEPEND="app-text/ghostscript
png? ( media-libs/libpng )"
src_compile() {
-
local myconf
use gif && myconf="${myconf} --enable-gif"
@@ -43,13 +40,12 @@ src_compile() {
--enable-paths \
--enable-wrapper"
- econf ${myconf} || die
+ econf ${myconf}
make || die
make check || die
}
-src_install () {
-
+src_install() {
dodir /usr/bin /usr/lib/latex2html /usr/share/latex2html
dodir /usr/share/texmf/tex/latex/html
cp cfgcache.pm cfgcache.pm.bak
diff --git a/app-text/mgv/mgv-3.1.5.ebuild b/app-text/mgv/mgv-3.1.5.ebuild
index 4318d0d0aa44..97ec948d1511 100644
--- a/app-text/mgv/mgv-3.1.5.ebuild
+++ b/app-text/mgv/mgv-3.1.5.ebuild
@@ -1,32 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/mgv-3.1.5.ebuild,v 1.11 2002/12/09 04:17:44 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/mgv-3.1.5.ebuild,v 1.12 2002/12/18 15:52:02 vapier Exp $
-
-S=${WORKDIR}/${P}
DESCRIPTION="Gv is a Motif PostScript viewer loosely based on Ghostview"
SRC_URI="http://www.trends.net/~mu/srcs/${P}.tar.gz"
HOMEPAGE="http://www.trends.net/~mu/mgv.html"
+
KEYWORDS="x86 sparc "
LICENSE="GPL-2"
+SLOT="0"
DEPEND=">=app-text/ghostscript-3.33
- x11-libs/openmotif"
-
-SLOT="0"
+ x11-libs/openmotif"
src_compile() {
-
- econf || die
+ econf
make || die
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README
dohtml doc/*.sgml
-
}
diff --git a/app-text/mlview/mlview-0.0.3_rc1.ebuild b/app-text/mlview/mlview-0.0.3_rc1.ebuild
index e558f105ca2f..86a3799efac7 100644
--- a/app-text/mlview/mlview-0.0.3_rc1.ebuild
+++ b/app-text/mlview/mlview-0.0.3_rc1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mlview/mlview-0.0.3_rc1.ebuild,v 1.1 2002/11/05 12:21:45 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mlview/mlview-0.0.3_rc1.ebuild,v 1.2 2002/12/18 15:53:22 vapier Exp $
+MY_P=${P/_/}
DESCRIPTION="XML Editor for Gnome"
HOMEPAGE="http://www.nongnu.org/mlview/"
-MY_P=${P/_/}
SRC_URI="http://savannah.gnu.org/download/${PN}/tarballs/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
@@ -18,20 +19,15 @@ DEPEND="gnome-base/gnome-libs
S="${WORKDIR}/${MY_P}"
src_compile() {
- local myconf=""
+ econf `use_enable nls`
- use nls || myconf="--disable-nls"
-
- econf $myconf || die "./configure failed"
-
# The presence of this file breaks the compilation without nls
[ -f ${S}/intl/libintl.h ] && rm ${S}/intl/libintl.h
-
+
emake || die "Compilation failed"
}
src_install() {
- einstall || die "Installation failed"
-
+ einstall
dodoc ABOUT-NLS AUTHORS BRANCHES COPYING ChangeLog NEWS README TODO
}