summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild8
-rw-r--r--games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild5
-rw-r--r--games-arcade/methane/methane-1.4.6.ebuild4
-rw-r--r--games-arcade/xtux/xtux-20030306.ebuild7
-rw-r--r--games-emulation/advancemame/advancemame-0.81.0.ebuild3
-rw-r--r--games-emulation/handy/handy-0.82.ebuild2
-rw-r--r--games-emulation/hugo/hugo-2.09.ebuild4
-rw-r--r--games-emulation/kigb/kigb-1.5.6.ebuild4
-rw-r--r--games-emulation/neopocott/neopocott-0.38b.ebuild2
9 files changed, 23 insertions, 16 deletions
diff --git a/games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild b/games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild
index 4dbe8ab1a5ab..88f1169bae44 100644
--- a/games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild
+++ b/games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/emilia-pinball/emilia-pinball-0.3.0.ebuild,v 1.7 2004/05/11 12:47:14 vapier Exp $
inherit games
@@ -9,19 +9,19 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="SDL OpenGL pinball game"
HOMEPAGE="http://pinball.sourceforge.net/"
SRC_URI="mirror://sourceforge/pinball/${MY_P}.tar.gz"
-RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 alpha"
+IUSE=""
RDEPEND="virtual/opengl
virtual/x11
media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer"
-
-DEPEND="$RDEPEND >=sys-devel/autoconf-2.58"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.58"
S=${WORKDIR}/${MY_P}
diff --git a/games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild b/games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild
index 66d50a057ae9..8e4f9a2aeca8 100644
--- a/games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild
+++ b/games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/emilia-pinball/emilia-pinball-0.3.1.ebuild,v 1.3 2004/05/11 12:47:14 vapier Exp $
inherit games
@@ -9,11 +9,10 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="SDL OpenGL pinball game"
HOMEPAGE="http://pinball.sourceforge.net/"
SRC_URI="mirror://sourceforge/pinball/${MY_P}.tar.gz"
-RESTRICT="nomirror"
-KEYWORDS="x86 alpha"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 alpha"
IUSE=""
DEPEND="virtual/opengl
diff --git a/games-arcade/methane/methane-1.4.6.ebuild b/games-arcade/methane/methane-1.4.6.ebuild
index 52141cadc26f..1e4574c26d79 100644
--- a/games-arcade/methane/methane-1.4.6.ebuild
+++ b/games-arcade/methane/methane-1.4.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.6.ebuild,v 1.4 2004/04/29 19:57:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.6.ebuild,v 1.5 2004/05/11 12:47:14 vapier Exp $
inherit games
-DESCRIPTION="Port from a old amiga game."
+DESCRIPTION="Port from an old amiga game"
HOMEPAGE="http://www.methane.fsnet.co.uk/"
SRC_URI="http://www.methane.fsnet.co.uk/${PN}.tgz"
diff --git a/games-arcade/xtux/xtux-20030306.ebuild b/games-arcade/xtux/xtux-20030306.ebuild
index a8f372b6a975..8cf0a93ec65e 100644
--- a/games-arcade/xtux/xtux-20030306.ebuild
+++ b/games-arcade/xtux/xtux-20030306.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/xtux-20030306.ebuild,v 1.5 2004/04/19 21:30:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/xtux-20030306.ebuild,v 1.6 2004/05/11 12:47:14 vapier Exp $
inherit games
-S="${WORKDIR}/${PN}"
DESCRIPTION="Multiplayer Gauntlet-style arcade game"
HOMEPAGE="http://xtux.sourceforge.net/"
SRC_URI="mirror://sourceforge/xtux/xtux-src-${PV}.tar.gz"
-KEYWORDS="x86 amd64"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 amd64"
IUSE=""
RDEPEND="virtual/x11"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}/${PN}"
+
src_compile() {
for f in src/{client,common,server}/Makefile ; do
sed -i \
diff --git a/games-emulation/advancemame/advancemame-0.81.0.ebuild b/games-emulation/advancemame/advancemame-0.81.0.ebuild
index 8be6b0d50753..12094a314e66 100644
--- a/games-emulation/advancemame/advancemame-0.81.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.81.0.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.81.0.ebuild,v 1.1 2004/04/08 20:29:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.81.0.ebuild,v 1.2 2004/05/11 12:51:22 vapier Exp $
inherit eutils games
-use debug && inherit debug
DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
HOMEPAGE="http://advancemame.sourceforge.net/"
diff --git a/games-emulation/handy/handy-0.82.ebuild b/games-emulation/handy/handy-0.82.ebuild
index ecef61a903c9..10cb5255396c 100644
--- a/games-emulation/handy/handy-0.82.ebuild
+++ b/games-emulation/handy/handy-0.82.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/handy/handy-0.82.ebuild,v 1.2 2004/05/11 12:51:22 vapier Exp $
inherit games
@@ -11,6 +12,7 @@ SRC_URI="http://sdlemu.ngemu.com/releases/Handy-SDL-${PV}${MY_RLS}.i386.linux-gl
LICENSE="as-is"
SLOT="0"
KEYWORDS="-* x86"
+IUSE=""
RDEPEND="media-libs/libsdl
sys-libs/zlib
diff --git a/games-emulation/hugo/hugo-2.09.ebuild b/games-emulation/hugo/hugo-2.09.ebuild
index 70c312c9ad57..8798066bb53c 100644
--- a/games-emulation/hugo/hugo-2.09.ebuild
+++ b/games-emulation/hugo/hugo-2.09.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/hugo-2.09.ebuild,v 1.3 2004/05/11 12:51:22 vapier Exp $
inherit games
@@ -10,6 +11,7 @@ SRC_URI="http://www.zeograd.com/download/hugo_lin_${PV//.}.tgz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
RDEPEND="virtual/x11
virtual/glibc
@@ -22,7 +24,7 @@ src_install() {
dodir ${dir}
exeinto ${dir}
- doexe hugo
+ doexe hugo || die
insinto ${dir}/roms
doins dracx.hcd flipit.pce
diff --git a/games-emulation/kigb/kigb-1.5.6.ebuild b/games-emulation/kigb/kigb-1.5.6.ebuild
index acccb03827af..f9914c3e00b4 100644
--- a/games-emulation/kigb/kigb-1.5.6.ebuild
+++ b/games-emulation/kigb/kigb-1.5.6.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/kigb/kigb-1.5.6.ebuild,v 1.2 2004/05/11 12:51:22 vapier Exp $
inherit games
@@ -10,6 +11,7 @@ SRC_URI="http://kigb.emuunlim.com/${PN}_lin.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
RDEPEND="dev-games/hawknl
virtual/x11
@@ -20,7 +22,7 @@ S=${WORKDIR}
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
dodir ${dir}
- cp -rf * ${D}/${dir}/
+ cp -rf * ${D}/${dir}/ || die
dogamesbin ${FILESDIR}/kigb
prepgamesdirs
}
diff --git a/games-emulation/neopocott/neopocott-0.38b.ebuild b/games-emulation/neopocott/neopocott-0.38b.ebuild
index 9dec26646551..51b55a2ebc11 100644
--- a/games-emulation/neopocott/neopocott-0.38b.ebuild
+++ b/games-emulation/neopocott/neopocott-0.38b.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/neopocott/neopocott-0.38b.ebuild,v 1.3 2004/05/11 12:51:22 vapier Exp $
inherit games
@@ -11,6 +12,7 @@ SRC_URI="http://sdlemu.ngemu.com/releases/NeoPocott-SDL-${PV}${MY_RLS}.i386.linu
LICENSE="as-is"
SLOT="0"
KEYWORDS="-* x86"
+IUSE=""
RDEPEND="media-libs/libsdl
sys-libs/zlib