summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/sysprof/ChangeLog8
-rw-r--r--dev-util/sysprof/sysprof-1.0.12-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/sysprof/ChangeLog b/dev-util/sysprof/ChangeLog
index 0fe102241620..9ed74f77e56d 100644
--- a/dev-util/sysprof/ChangeLog
+++ b/dev-util/sysprof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/sysprof
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.14 2009/01/26 03:21:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.15 2009/05/27 11:02:05 remi Exp $
+
+*sysprof-1.0.12-r1 (27 May 2009)
+
+ 27 May 2009; Rémi Cardona <remi@gentoo.org> +sysprof-1.0.12-r1.ebuild:
+ fix missing depmod in pkg_postinst which is done by the linux-mod eclass:
+ modprobe is now able to see sysprof_module
26 Jan 2009; Mart Raudsepp <leio@gentoo.org> sysprof-1.0.12.ebuild:
Add einfo about frame pointers and the lack of them affecting sysprof
diff --git a/dev-util/sysprof/sysprof-1.0.12-r1.ebuild b/dev-util/sysprof/sysprof-1.0.12-r1.ebuild
new file mode 100644
index 000000000000..68b8b4fc295b
--- /dev/null
+++ b/dev-util/sysprof/sysprof-1.0.12-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.12-r1.ebuild,v 1.1 2009/05/27 11:02:05 remi Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ x11-libs/pango
+ >=gnome-base/libglade-2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ MODULE_NAMES="sysprof-module(misc:${S}/module)"
+ CONFIG_CHECK="PROFILING"
+ PROFILING_ERROR="You need to enable Profiling support in your kernel. \
+For this you need to enable 'Profiling support' under 'Instrumentation Support'. \
+It is marked CONFIG_PROFILING in the config file"
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ econf --disable-kernel-module || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry sysprof Sysprof sysprof-icon
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo "On many systems, especially amd64, it is typical that with a modern"
+ einfo "toolchain -fomit-frame-pointer for gcc is the default, because"
+ einfo "debugging is still possible thanks to gcc4/gdb location list feature."
+ einfo "However sysprof is not able to construct call trees if frame pointers"
+ einfo "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ einfo "for the libraries and applications involved in the profiling. That"
+ einfo "means a CPU register is used for the frame pointer instead of other"
+ einfo "purposes, which means a very minimal performance loss when there is"
+ einfo "register pressure."
+}