summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/wkhtmltopdf/ChangeLog9
-rw-r--r--media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.2.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/media-gfx/wkhtmltopdf/ChangeLog b/media-gfx/wkhtmltopdf/ChangeLog
index fd87f57affa0..749b0dac399f 100644
--- a/media-gfx/wkhtmltopdf/ChangeLog
+++ b/media-gfx/wkhtmltopdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/wkhtmltopdf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/ChangeLog,v 1.4 2014/11/27 05:03:51 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/ChangeLog,v 1.5 2015/01/20 22:29:52 radhermit Exp $
+
+*wkhtmltopdf-0.12.2.1 (20 Jan 2015)
+
+ 20 Jan 2015; Tim Harder <radhermit@gentoo.org> +wkhtmltopdf-0.12.2.1.ebuild:
+ Version bump.
*wkhtmltopdf-0.12.1.2 (27 Nov 2014)
diff --git a/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.2.1.ebuild b/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.2.1.ebuild
new file mode 100644
index 000000000000..230b989fe287
--- /dev/null
+++ b/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wkhtmltopdf/wkhtmltopdf-0.12.2.1.ebuild,v 1.1 2015/01/20 22:29:52 radhermit Exp $
+
+EAPI=5
+
+inherit qt4-r2 multilib eutils
+
+DESCRIPTION="Convert html to pdf (and various image formats) using webkit"
+HOMEPAGE="http://wkhtmltopdf.org/ https://github.com/wkhtmltopdf/wkhtmltopdf/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtcore:4
+ dev-qt/qtsvg:4
+ dev-qt/qtxmlpatterns:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # fix install paths and don't precompress man pages
+ epatch "${FILESDIR}"/${PN}-0.12.1.2-manpages.patch
+
+ sed -i "s:\(INSTALLBASE/\)lib:\1$(get_libdir):" src/lib/lib.pro || die
+}
+
+src_configure() {
+ eqmake4 INSTALLBASE=/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc AUTHORS CHANGELOG* README.md
+ use examples && dodoc -r examples
+}