summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.8-r3.ebuild200
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.8-r4.ebuild203
-rw-r--r--kde-base/kdelibs/kdelibs-4.0.2.ebuild211
-rw-r--r--kde-base/kdelibs/kdelibs-4.0.3-r1.ebuild212
5 files changed, 6 insertions, 827 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 1c5a04b0d0de..070f895b71fc 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.534 2008/06/05 21:32:09 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.535 2008/06/07 11:29:04 keytoaster Exp $
+
+ 07 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ -kdelibs-3.5.8-r3.ebuild, -kdelibs-3.5.8-r4.ebuild, -kdelibs-4.0.2.ebuild,
+ -kdelibs-4.0.3-r1.ebuild:
+ Removed old versions.
*kdelibs-4.0.5 (05 Jun 2008)
diff --git a/kde-base/kdelibs/kdelibs-3.5.8-r3.ebuild b/kde-base/kdelibs/kdelibs-3.5.8-r3.ebuild
deleted file mode 100644
index 6a52adf766da..000000000000
--- a/kde-base/kdelibs/kdelibs-3.5.8-r3.ebuild
+++ /dev/null
@@ -1,200 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.8-r3.ebuild,v 1.8 2008/02/18 15:42:20 ingmar Exp $
-
-inherit kde flag-o-matic eutils multilib
-set-kdedir 3.5
-
-DESCRIPTION="KDE libraries needed by all KDE programs."
-HOMEPAGE="http://www.kde.org/"
-SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
- mirror://gentoo/kdelibs-3.5-patchset-14.tar.bz2
- mirror://gentoo/${P}-seli-xinerama.patch.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="3.5"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="acl alsa arts bindist branding cups doc jpeg2k kerberos legacyssl utempter openexr spell tiff
- avahi kernel_linux fam lua kdehiddenvisibility"
-
-# Added aspell-en as dependency to work around bug 131512.
-# Made openssl and zeroconf mandatory dependencies, see bug #172972 and #175984
-RDEPEND="$(qt_min_version 3.3.3)
- arts? ( >=kde-base/arts-3.5.5 )
- app-arch/bzip2
- >=media-libs/freetype-2
- media-libs/fontconfig
- >=dev-libs/libxslt-1.1.16
- >=dev-libs/libxml2-2.6.6
- >=dev-libs/libpcre-6.6
- media-libs/libart_lgpl
- net-dns/libidn
- >=dev-libs/openssl-0.9.7d
- acl? ( kernel_linux? ( sys-apps/acl ) )
- alsa? ( media-libs/alsa-lib )
- cups? ( >=net-print/cups-1.1.19 )
- tiff? ( media-libs/tiff )
- kerberos? ( virtual/krb5 )
- jpeg2k? ( media-libs/jasper )
- openexr? ( >=media-libs/openexr-1.2.2-r2 )
- !avahi? ( !bindist? ( net-misc/mDNSResponder !kde-misc/kdnssd-avahi ) )
- fam? ( virtual/fam )
- virtual/ghostscript
- utempter? ( sys-libs/libutempter )
- !kde-base/kde-env
- lua? ( dev-lang/lua )
- spell? ( >=app-text/aspell-0.60.5 >=app-dicts/aspell-en-6.0.0 )
- >=sys-apps/portage-2.1.2.11
- !kde-base/ksync"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- sys-devel/gettext"
-
-RDEPEND="${RDEPEND}
- x11-apps/rgb
- x11-apps/iceauth"
-
-PDEPEND="avahi? ( kde-misc/kdnssd-avahi )
- bindist? ( kde-misc/kdnssd-avahi )"
-
-# Testing code is rather broken and merely for developer purposes, so disable it.
-RESTRICT="test"
-
-pkg_setup() {
- if use legacyssl ; then
- echo ""
- elog "You have the legacyssl use flag enabled, which fixes issues with some broken"
- elog "sites, but breaks others instead. It is strongly discouraged to use it."
- elog "For more information, see bug #128922."
- echo ""
- fi
-
- if ! use utempter ; then
- echo ""
- elog "On some setups, which rely on the correct update of utmp records, not using"
- elog "utempter might not update them correctly. If you experience unexpected"
- elog "behaviour, try to rebuild kde-base/kdelibs with utempter use-flag enabled."
- echo ""
- fi
-
- if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
- eerror "The alsa USE flag in this package enables ALSA support"
- eerror "for libkmid, KDE midi library."
- eerror "For this reason, you have to merge media-libs/alsa-lib"
- eerror "with the midi USE flag enabled, or disable alsa USE flag"
- eerror "for this package."
- die "Missing midi USE flag on media-libs/alsa-lib"
- fi
-}
-
-src_unpack() {
- kde_src_unpack
-
- if use legacyssl ; then
- # This patch won't be included upstream, see bug #128922.
- epatch "${WORKDIR}/patches/kdelibs_3.5.4-kssl-3des.patch"
- fi
-
- if use utempter ; then
- # Bug #135818 is the eternal reference.
- epatch "${WORKDIR}/patches/kdelibs-3.5_libutempter.patch"
- fi
-
- if use branding ; then
- # Add "(Gentoo)" to khtml user agent.
- epatch "${WORKDIR}/patches/kdelibs_3.5-cattlebrand.diff"
- fi
-
- # Xinerama patch from Lubos Lunak.
- # http://ktown.kde.org/~seli/xinerama/
- epatch "${WORKDIR}/${P}-seli-xinerama.patch"
-}
-
-src_compile() {
- rm -f "${S}/configure"
-
- myconf="--with-distribution=Gentoo --disable-fast-malloc
- --with-libart --with-libidn --with-ssl
- --without-hspell
- $(use_enable fam libfam) $(use_enable kernel_linux dnotify)
- $(use_with acl) $(use_with alsa)
- $(use_with arts) $(use_enable cups)
- $(use_with kerberos gssapi) $(use_with tiff)
- $(use_with jpeg2k jasper) $(use_with openexr)
- $(use_with utempter) $(use_with lua)
- $(use_enable kernel_linux sendfile) --enable-mitshm
- $(use_with spell aspell)"
-
- if use avahi || use bindist ; then
- myconf="${myconf} --disable-dnssd"
- else
- myconf="${myconf} --enable-dnssd"
- fi
-
- if has_version x11-apps/rgb; then
- myconf="${myconf} --with-rgbfile=/usr/share/X11/rgb.txt"
- fi
-
- # fix bug 58179, bug 85593
- # kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
- # closer look... - corsair
- use ppc64 && append-flags "-mminimal-toc"
-
- # work around bug #120858, gcc 3.4.x -Os miscompilation
- use x86 && replace-flags "-Os" "-O2" # see bug #120858
-
- replace-flags "-O3" "-O2" # see bug #148180
-
- kde_src_compile
-
- if use doc; then
- make apidox || die
- fi
-}
-
-src_install() {
- kde_src_install
-
- if use doc; then
- make DESTDIR="${D}" install-apidox || die
- fi
-
- # Needed to create lib -> lib64 symlink for amd64 2005.0 profile
- if [ "${SYMLINK_LIB}" = "yes" ]; then
- dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
- fi
-
- # Get rid of the disabled version of the kdnsd libraries
- if use avahi || use bindist ; then
- rm -rf "${D}/${PREFIX}"/$(get_libdir)/libkdnssd.*
- fi
-
- dodir /etc/env.d
-
- # List all the multilib libdirs
- local libdirs
- for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:${PREFIX}/${libdir}"
- done
-
- # Please note that the KDE install path has to be the last value in KDEDIRS.
- cat <<EOF > "${D}"/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
-PATH=${PREFIX}/bin
-ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
-LDPATH=${libdirs:1}
-MANPATH=${PREFIX}/share/man
-CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
-KDEDIRS="/usr:/usr/local:${PREFIX}"
-#KDE_IS_PRELINKED=1
-XDG_DATA_DIRS="/usr/share:${PREFIX}/share:/usr/local/share"
-COLON_SEPARATED="XDG_DATA_DIRS"
-EOF
-
- # Make sure the target for the revdep-rebuild stuff exists. Fixes bug 184441.
- dodir /etc/revdep-rebuild
-
-cat <<EOF > "${D}"/etc/revdep-rebuild/50-kde3
-SEARCH_DIRS="${PREFIX}/bin ${PREFIX}/lib*"
-EOF
-}
diff --git a/kde-base/kdelibs/kdelibs-3.5.8-r4.ebuild b/kde-base/kdelibs/kdelibs-3.5.8-r4.ebuild
deleted file mode 100644
index ffd2adae3fcc..000000000000
--- a/kde-base/kdelibs/kdelibs-3.5.8-r4.ebuild
+++ /dev/null
@@ -1,203 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.8-r4.ebuild,v 1.1 2008/04/28 12:32:23 jer Exp $
-
-inherit kde flag-o-matic eutils multilib
-set-kdedir 3.5
-
-DESCRIPTION="KDE libraries needed by all KDE programs."
-HOMEPAGE="http://www.kde.org/"
-SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
- mirror://gentoo/kdelibs-3.5-patchset-14.tar.bz2
- mirror://gentoo/${P}-seli-xinerama.patch.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="3.5"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="acl alsa arts bindist branding cups doc jpeg2k kerberos legacyssl utempter openexr spell tiff
- avahi kernel_linux fam lua kdehiddenvisibility"
-
-# Added aspell-en as dependency to work around bug 131512.
-# Made openssl and zeroconf mandatory dependencies, see bug #172972 and #175984
-RDEPEND="$(qt_min_version 3.3.3)
- arts? ( >=kde-base/arts-3.5.5 )
- app-arch/bzip2
- >=media-libs/freetype-2
- media-libs/fontconfig
- >=dev-libs/libxslt-1.1.16
- >=dev-libs/libxml2-2.6.6
- >=dev-libs/libpcre-6.6
- media-libs/libart_lgpl
- net-dns/libidn
- >=dev-libs/openssl-0.9.7d
- acl? ( kernel_linux? ( sys-apps/acl ) )
- alsa? ( media-libs/alsa-lib )
- cups? ( >=net-print/cups-1.1.19 )
- tiff? ( media-libs/tiff )
- kerberos? ( virtual/krb5 )
- jpeg2k? ( media-libs/jasper )
- openexr? ( >=media-libs/openexr-1.2.2-r2 )
- !avahi? ( !bindist? ( net-misc/mDNSResponder !kde-misc/kdnssd-avahi ) )
- fam? ( virtual/fam )
- virtual/ghostscript
- utempter? ( sys-libs/libutempter )
- !kde-base/kde-env
- lua? ( dev-lang/lua )
- spell? ( >=app-text/aspell-0.60.5 >=app-dicts/aspell-en-6.0.0 )
- >=sys-apps/portage-2.1.2.11
- !kde-base/ksync"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- sys-devel/gettext"
-
-RDEPEND="${RDEPEND}
- x11-apps/rgb
- x11-apps/iceauth"
-
-PDEPEND="avahi? ( kde-misc/kdnssd-avahi )
- bindist? ( kde-misc/kdnssd-avahi )"
-
-# Testing code is rather broken and merely for developer purposes, so disable it.
-RESTRICT="test"
-
-pkg_setup() {
- if use legacyssl ; then
- echo ""
- elog "You have the legacyssl use flag enabled, which fixes issues with some broken"
- elog "sites, but breaks others instead. It is strongly discouraged to use it."
- elog "For more information, see bug #128922."
- echo ""
- fi
-
- if ! use utempter ; then
- echo ""
- elog "On some setups, which rely on the correct update of utmp records, not using"
- elog "utempter might not update them correctly. If you experience unexpected"
- elog "behaviour, try to rebuild kde-base/kdelibs with utempter use-flag enabled."
- echo ""
- fi
-
- if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
- eerror "The alsa USE flag in this package enables ALSA support"
- eerror "for libkmid, KDE midi library."
- eerror "For this reason, you have to merge media-libs/alsa-lib"
- eerror "with the midi USE flag enabled, or disable alsa USE flag"
- eerror "for this package."
- die "Missing midi USE flag on media-libs/alsa-lib"
- fi
-}
-
-src_unpack() {
- kde_src_unpack
-
- if use legacyssl ; then
- # This patch won't be included upstream, see bug #128922.
- epatch "${WORKDIR}/patches/kdelibs_3.5.4-kssl-3des.patch"
- fi
-
- if use utempter ; then
- # Bug #135818 is the eternal reference.
- epatch "${WORKDIR}/patches/kdelibs-3.5_libutempter.patch"
- fi
-
- if use branding ; then
- # Add "(Gentoo)" to khtml user agent.
- epatch "${WORKDIR}/patches/kdelibs_3.5-cattlebrand.diff"
- fi
-
- # Xinerama patch from Lubos Lunak.
- # http://ktown.kde.org/~seli/xinerama/
- epatch "${WORKDIR}/${P}-seli-xinerama.patch"
-
- # Security bug 218933
- epatch "${FILESDIR}/${P}-kinit-CVE-2008-1671.patch"
-}
-
-src_compile() {
- rm -f "${S}/configure"
-
- myconf="--with-distribution=Gentoo --disable-fast-malloc
- --with-libart --with-libidn --with-ssl
- --without-hspell
- $(use_enable fam libfam) $(use_enable kernel_linux dnotify)
- $(use_with acl) $(use_with alsa)
- $(use_with arts) $(use_enable cups)
- $(use_with kerberos gssapi) $(use_with tiff)
- $(use_with jpeg2k jasper) $(use_with openexr)
- $(use_with utempter) $(use_with lua)
- $(use_enable kernel_linux sendfile) --enable-mitshm
- $(use_with spell aspell)"
-
- if use avahi || use bindist ; then
- myconf="${myconf} --disable-dnssd"
- else
- myconf="${myconf} --enable-dnssd"
- fi
-
- if has_version x11-apps/rgb; then
- myconf="${myconf} --with-rgbfile=/usr/share/X11/rgb.txt"
- fi
-
- # fix bug 58179, bug 85593
- # kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
- # closer look... - corsair
- use ppc64 && append-flags "-mminimal-toc"
-
- # work around bug #120858, gcc 3.4.x -Os miscompilation
- use x86 && replace-flags "-Os" "-O2" # see bug #120858
-
- replace-flags "-O3" "-O2" # see bug #148180
-
- kde_src_compile
-
- if use doc; then
- make apidox || die
- fi
-}
-
-src_install() {
- kde_src_install
-
- if use doc; then
- make DESTDIR="${D}" install-apidox || die
- fi
-
- # Needed to create lib -> lib64 symlink for amd64 2005.0 profile
- if [ "${SYMLINK_LIB}" = "yes" ]; then
- dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
- fi
-
- # Get rid of the disabled version of the kdnsd libraries
- if use avahi || use bindist ; then
- rm -rf "${D}/${PREFIX}"/$(get_libdir)/libkdnssd.*
- fi
-
- dodir /etc/env.d
-
- # List all the multilib libdirs
- local libdirs
- for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:${PREFIX}/${libdir}"
- done
-
- # Please note that the KDE install path has to be the last value in KDEDIRS.
- cat <<EOF > "${D}"/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
-PATH=${PREFIX}/bin
-ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
-LDPATH=${libdirs:1}
-MANPATH=${PREFIX}/share/man
-CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
-KDEDIRS="/usr:/usr/local:${PREFIX}"
-#KDE_IS_PRELINKED=1
-XDG_DATA_DIRS="/usr/share:${PREFIX}/share:/usr/local/share"
-COLON_SEPARATED="XDG_DATA_DIRS"
-EOF
-
- # Make sure the target for the revdep-rebuild stuff exists. Fixes bug 184441.
- dodir /etc/revdep-rebuild
-
-cat <<EOF > "${D}"/etc/revdep-rebuild/50-kde3
-SEARCH_DIRS="${PREFIX}/bin ${PREFIX}/lib*"
-EOF
-}
diff --git a/kde-base/kdelibs/kdelibs-4.0.2.ebuild b/kde-base/kdelibs/kdelibs-4.0.2.ebuild
deleted file mode 100644
index 9cb5a417fafc..000000000000
--- a/kde-base/kdelibs/kdelibs-4.0.2.ebuild
+++ /dev/null
@@ -1,211 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-4.0.2.ebuild,v 1.1 2008/03/10 23:33:14 philantrop Exp $
-
-EAPI="1"
-
-CPPUNIT_REQUIRED="optional"
-OPENGL_REQUIRED="optional"
-inherit kde4-base
-
-DESCRIPTION="KDE libraries needed by all KDE programs."
-HOMEPAGE="http://www.kde.org/"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="3dnow acl alsa altivec bindist +bzip2 debug doc fam htmlhandbook jpeg2k
-kerberos mmx nls openexr +semantic-desktop spell sse sse2 ssl zeroconf"
-LICENSE="GPL-2 LGPL-2"
-RESTRICT="test"
-
-COMMONDEPEND="
- !<kde-base/kdebase-3.5.7-r6
- !<kde-base/kdebase-startkde-3.5.7-r1
- !=kde-base/kdebase-3.5.8
- !=kde-base/kdebase-3.5.8-r1
- !=kde-base/kdebase-3.5.8-r2
- !=kde-base/kdebase-startkde-3.5.8
- >=app-misc/strigi-0.5.7
- >=dev-libs/libxml2-2.6.6
- >=dev-libs/libxslt-1.1.17
- media-libs/fontconfig
- >=media-libs/freetype-2
- media-libs/giflib
- media-libs/jpeg
- media-libs/libpng
- >=sys-apps/dbus-0.91
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXcursor
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXrender
- x11-libs/libXtst
- >=x11-misc/shared-mime-info-0.20
- acl? ( kernel_linux? ( sys-apps/acl ) )
- alsa? ( >=media-libs/alsa-lib-1.0.14a )
- fam? ( virtual/fam )
- jpeg2k? ( media-libs/jasper )
- kerberos? ( virtual/krb5 )
- nls? ( virtual/libintl )
- openexr? ( >=media-libs/openexr-1.2.2-r2 media-libs/ilmbase )
- opengl? ( virtual/opengl )
- >=dev-libs/libpcre-4.5
- semantic-desktop? ( >=dev-libs/soprano-2.0.0 )
- spell? ( app-text/aspell app-dicts/aspell-en app-text/enchant )
- ssl? ( >=dev-libs/openssl-0.9.7d )
- zeroconf? ( || ( net-dns/avahi
- !bindist? ( net-misc/mDNSResponder ) ) )
-"
-
-DEPEND="${COMMONDEPEND}
- doc? ( app-doc/doxygen )
- sys-devel/gettext"
-
-RDEPEND="${COMMONDEPEND}
- x11-apps/rgb
- x11-apps/iceauth"
-
-# Patch to respect the sandbox when cmake tries to create symlinks,
-# or executes an external program that tries to write files.
-PATCHES="${FILESDIR}/e-tempdir.patch
-${FILESDIR}/${P}-X11-optional.patch
-${FILESDIR}/${P}-alsa-optional.patch"
-# Create CMake switches to make Xcomposite, Xinerama & Xscreensaver optional.
-
-pkg_setup() {
- if has_version x11-libs/qt-core:4; then
- ewarn "KDE 4.0.2 doesn't work well with Qt-4.4, expect strange bugs."
- ewarn "It is highly recommend, that you install x11-libs/qt-4.3.4,"
- ewarn "recompile ${P} and all of its dependencies if you want"
- ewarn "to use KDE 4.0.2."
- fi
- KDE4_BUILT_WITH_USE_CHECK="--missing true sys-apps/dbus X"
- use alsa && KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
- --missing true media-libs/alsa-lib midi"
- if use zeroconf && has_version net-dns/avahi; then
- KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
- net-dns/avahi mdnsresponder-compat"
- fi
-
- kde4-base_pkg_setup
-}
-
-src_compile() {
- if use zeroconf; then
- if has_version net-dns/avahi; then
- mycmakeargs="${mycmakeargs} -DWITH_Avahi=ON -DWITH_DNSSD=OFF"
- elif has_version net-misc/mDNSResponder; then
- mycmakeargs="${mycmakeargs} -DWITH_Avahi=OFF -DWITH_DNSSD=ON"
- else
- die "USE=\"zeroconf\" enabled but neither net-dns/avahi nor net-misc/mDNSResponder were found."
- fi
- fi
-
- mycmakeargs="${mycmakeargs}
- -DWITH_HSPELL=OFF
- $(cmake-utils_has 3dnow X86_3DNOW)
- $(cmake-utils_has altivec PPC_ALTIVEC)
- $(cmake-utils_has mmx X86_MMX)
- $(cmake-utils_has sse X86_SSE)
- $(cmake-utils_has sse2 X86_SSE2)
- $(cmake-utils_use_with acl ACL)
- $(cmake-utils_use_with alsa Alsa)
- $(cmake-utils_use_with bzip2 BZip2)
- $(cmake-utils_use_with fam FAM)
- $(cmake-utils_use_with jpeg2k Jasper)
- $(cmake-utils_use_with kerberos GSSAPI)
- $(cmake-utils_use_with nls Libintl)
- $(cmake-utils_use_with openexr OpenEXR)
- $(cmake-utils_use_with opengl OpenGL)
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with spell ASPELL)
- $(cmake-utils_use_with spell ENCHANT)
- $(cmake-utils_use_with ssl OpenSSL)
- "
-
- kde4-base_src_compile
-
- # The building of apidox is not managed anymore by the build system
- if use doc; then
- einfo "Building API documentation"
- cd "${S}"/doc/api/
- ./doxygen.sh "${S}" || die "APIDOX generation failed"
- fi
-}
-
-src_install() {
- kde4-base_src_install
-
- # Some external applications need FindXine.cmake. Therefore upstream moved it
- # to kdelibs in trunk. Doing the same for :kde-4. See bug #209701.
- insinto ${KDEDIR}/share/apps/cmake/modules/
- doins "${FILESDIR}"/FindXine.cmake || die "doins FindXine failed."
-
- if use doc; then
- einfo "Installing API documentation. This could take a bit of time."
- cd "${S}"/doc/api/
- docinto /HTML/en/kdelibs-apidox
- dohtml -r ${P}-apidocs/* || die "Install phase of KDE4 API Documentation failed"
- fi
-
- dodir /etc/env.d
- dodir /etc/revdep-rebuild
-
- # List all the multilib libdirs
- local _libdir _libdirs
- for _libdir in $(get_all_libdirs); do
- _libdirs="${_libdirs}:${PREFIX}/${_libdir}"
- done
- _libdirs=${_libdirs#:}
-
- cat <<-EOF > "${T}"/44kdepaths-${SLOT} # number goes down with version bump
- PATH="${PREFIX}/bin"
- ROOTPATH="${PREFIX}/sbin:${PREFIX}/bin"
- LDPATH="${_libdirs}"
- MANPATH="${PREFIX}/share/man"
- CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
- KDEDIRS="/usr:/usr/local:${PREFIX}"
- #KDE_IS_PRELINKED=1
- XDG_DATA_DIRS="/usr/share:${PREFIX}/share:/usr/local/share"
- COLON_SEPARATED="XDG_DATA_DIRS"
- EOF
- doenvd "${T}"/44kdepaths-${SLOT}
-
- # make sure 'source /etc/profile' doesn't hose the PATH
- dodir /etc/profile.d
- cat <<-'EOF' > "${D}"/etc/profile.d/44kdereorderpaths-${SLOT}.sh
- if [ -n "${KDEDIR}" ]; then
- export PATH=${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
- export ROOTPATH=${KDEDIR}/sbin:${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
- fi
- EOF
-
- cat <<-EOF > "${D}/etc/revdep-rebuild/50-kde-${SLOT}"
- SEARCH_DIRS="${PREFIX}/bin ${PREFIX}/lib*"
- EOF
-}
-
-src_test() {
- # FIXME: Disable kate tests
- mycmakeargs="${mycmakeargs}
- -DKHTML_BUILD_TESTREGRESSION=ON"
- kde4-base_src_test
-}
-
-pkg_postinst() {
- if use zeroconf; then
- echo
- elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
- elog "is running. Make sure also that multicast dns lookups are enabled by editing"
- elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
- echo
- fi
-
- kde4-base_pkg_postinst
-}
diff --git a/kde-base/kdelibs/kdelibs-4.0.3-r1.ebuild b/kde-base/kdelibs/kdelibs-4.0.3-r1.ebuild
deleted file mode 100644
index 790d41a61ad6..000000000000
--- a/kde-base/kdelibs/kdelibs-4.0.3-r1.ebuild
+++ /dev/null
@@ -1,212 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-4.0.3-r1.ebuild,v 1.1 2008/04/28 14:10:31 ingmar Exp $
-
-EAPI="1"
-
-CPPUNIT_REQUIRED="optional"
-OPENGL_REQUIRED="optional"
-inherit kde4-base
-
-DESCRIPTION="KDE libraries needed by all KDE programs."
-HOMEPAGE="http://www.kde.org/"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="3dnow acl alsa altivec bindist +bzip2 debug doc fam htmlhandbook jpeg2k
-kerberos mmx nls openexr +semantic-desktop spell sse sse2 ssl zeroconf"
-LICENSE="GPL-2 LGPL-2"
-RESTRICT="test"
-
-COMMONDEPEND="
- !<kde-base/kdebase-3.5.7-r6
- !<kde-base/kdebase-startkde-3.5.7-r1
- !=kde-base/kdebase-3.5.8
- !=kde-base/kdebase-3.5.8-r1
- !=kde-base/kdebase-3.5.8-r2
- !=kde-base/kdebase-startkde-3.5.8
- >=app-misc/strigi-0.5.7
- >=dev-libs/libxml2-2.6.6
- >=dev-libs/libxslt-1.1.17
- media-libs/fontconfig
- >=media-libs/freetype-2
- media-libs/giflib
- media-libs/jpeg
- media-libs/libpng
- >=sys-apps/dbus-0.91
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXcursor
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXrender
- x11-libs/libXtst
- >=x11-misc/shared-mime-info-0.20
- acl? ( kernel_linux? ( sys-apps/acl ) )
- alsa? ( >=media-libs/alsa-lib-1.0.14a )
- fam? ( virtual/fam )
- jpeg2k? ( media-libs/jasper )
- kerberos? ( virtual/krb5 )
- nls? ( virtual/libintl )
- openexr? ( >=media-libs/openexr-1.2.2-r2 media-libs/ilmbase )
- opengl? ( virtual/opengl )
- >=dev-libs/libpcre-4.5
- semantic-desktop? ( >=dev-libs/soprano-2.0.0 )
- spell? ( app-text/aspell app-dicts/aspell-en app-text/enchant )
- ssl? ( >=dev-libs/openssl-0.9.7d )
- zeroconf? ( || ( net-dns/avahi
- !bindist? ( net-misc/mDNSResponder ) ) )
-"
-
-DEPEND="${COMMONDEPEND}
- doc? ( app-doc/doxygen )
- sys-devel/gettext"
-
-RDEPEND="${COMMONDEPEND}
- x11-apps/rgb
- x11-apps/iceauth"
-
-# Patch to respect the sandbox when cmake tries to create symlinks,
-# or executes an external program that tries to write files.
-PATCHES="${FILESDIR}/e-tempdir.patch
-${FILESDIR}/${PN}-4.0.2-X11-optional.patch
-${FILESDIR}/${PN}-4.0.2-alsa-optional.patch
-${FILESDIR}/${P}-CVS-2008-1670.patch"
-# Create CMake switches to make Xcomposite, Xinerama & Xscreensaver optional.
-
-pkg_setup() {
- if has_version x11-libs/qt-core:4; then
- ewarn "KDE ${PV} doesn't work well with Qt-4.4, expect strange bugs."
- ewarn "It is highly recommend, that you install x11-libs/qt-4.3.4,"
- ewarn "recompile ${P} and all of its dependencies if you want"
- ewarn "to use KDE 4.0.2."
- fi
- KDE4_BUILT_WITH_USE_CHECK="--missing true sys-apps/dbus X"
- use alsa && KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
- --missing true media-libs/alsa-lib midi"
- if use zeroconf && has_version net-dns/avahi; then
- KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
- net-dns/avahi mdnsresponder-compat"
- fi
-
- kde4-base_pkg_setup
-}
-
-src_compile() {
- if use zeroconf; then
- if has_version net-dns/avahi; then
- mycmakeargs="${mycmakeargs} -DWITH_Avahi=ON -DWITH_DNSSD=OFF"
- elif has_version net-misc/mDNSResponder; then
- mycmakeargs="${mycmakeargs} -DWITH_Avahi=OFF -DWITH_DNSSD=ON"
- else
- die "USE=\"zeroconf\" enabled but neither net-dns/avahi nor net-misc/mDNSResponder were found."
- fi
- fi
-
- mycmakeargs="${mycmakeargs}
- -DWITH_HSPELL=OFF
- $(cmake-utils_has 3dnow X86_3DNOW)
- $(cmake-utils_has altivec PPC_ALTIVEC)
- $(cmake-utils_has mmx X86_MMX)
- $(cmake-utils_has sse X86_SSE)
- $(cmake-utils_has sse2 X86_SSE2)
- $(cmake-utils_use_with acl ACL)
- $(cmake-utils_use_with alsa Alsa)
- $(cmake-utils_use_with bzip2 BZip2)
- $(cmake-utils_use_with fam FAM)
- $(cmake-utils_use_with jpeg2k Jasper)
- $(cmake-utils_use_with kerberos GSSAPI)
- $(cmake-utils_use_with nls Libintl)
- $(cmake-utils_use_with openexr OpenEXR)
- $(cmake-utils_use_with opengl OpenGL)
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with spell ASPELL)
- $(cmake-utils_use_with spell ENCHANT)
- $(cmake-utils_use_with ssl OpenSSL)
- "
-
- kde4-base_src_compile
-
- # The building of apidox is not managed anymore by the build system
- if use doc; then
- einfo "Building API documentation"
- cd "${S}"/doc/api/
- ./doxygen.sh "${S}" || die "APIDOX generation failed"
- fi
-}
-
-src_install() {
- kde4-base_src_install
-
- # Some external applications need FindXine.cmake. Therefore upstream moved it
- # to kdelibs in trunk. Doing the same for :kde-4. See bug #209701.
- insinto ${KDEDIR}/share/apps/cmake/modules/
- doins "${FILESDIR}"/FindXine.cmake || die "doins FindXine failed."
-
- if use doc; then
- einfo "Installing API documentation. This could take a bit of time."
- cd "${S}"/doc/api/
- docinto /HTML/en/kdelibs-apidox
- dohtml -r ${P}-apidocs/* || die "Install phase of KDE4 API Documentation failed"
- fi
-
- dodir /etc/env.d
- dodir /etc/revdep-rebuild
-
- # List all the multilib libdirs
- local _libdir _libdirs
- for _libdir in $(get_all_libdirs); do
- _libdirs="${_libdirs}:${PREFIX}/${_libdir}"
- done
- _libdirs=${_libdirs#:}
-
- cat <<-EOF > "${T}"/44kdepaths-${SLOT} # number goes down with version bump
- PATH="${PREFIX}/bin"
- ROOTPATH="${PREFIX}/sbin:${PREFIX}/bin"
- LDPATH="${_libdirs}"
- MANPATH="${PREFIX}/share/man"
- CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
- KDEDIRS="/usr:/usr/local:${PREFIX}"
- #KDE_IS_PRELINKED=1
- XDG_DATA_DIRS="/usr/share:${PREFIX}/share:/usr/local/share"
- COLON_SEPARATED="XDG_DATA_DIRS"
- EOF
- doenvd "${T}"/44kdepaths-${SLOT}
-
- # make sure 'source /etc/profile' doesn't hose the PATH
- dodir /etc/profile.d
- cat <<-'EOF' > "${D}"/etc/profile.d/44kdereorderpaths-${SLOT}.sh
- if [ -n "${KDEDIR}" ]; then
- export PATH=${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
- export ROOTPATH=${KDEDIR}/sbin:${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
- fi
- EOF
-
- cat <<-EOF > "${D}/etc/revdep-rebuild/50-kde-${SLOT}"
- SEARCH_DIRS="${PREFIX}/bin ${PREFIX}/lib*"
- EOF
-}
-
-src_test() {
- # FIXME: Disable kate tests
- mycmakeargs="${mycmakeargs}
- -DKHTML_BUILD_TESTREGRESSION=ON"
- kde4-base_src_test
-}
-
-pkg_postinst() {
- if use zeroconf; then
- echo
- elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
- elog "is running. Make sure also that multicast dns lookups are enabled by editing"
- elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
- echo
- fi
-
- kde4-base_pkg_postinst
-}