summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/tilt/ChangeLog6
-rw-r--r--dev-ruby/tilt/files/tilt-1.3.2-thread_id.patch19
-rw-r--r--dev-ruby/tilt/tilt-1.3.2.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-ruby/tilt/ChangeLog b/dev-ruby/tilt/ChangeLog
index 65c4b2536443..17d185e3224d 100644
--- a/dev-ruby/tilt/ChangeLog
+++ b/dev-ruby/tilt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/tilt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.12 2011/07/24 09:42:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.13 2011/07/25 18:07:28 graaff Exp $
+
+ 25 Jul 2011; Hans de Graaff <graaff@gentoo.org> tilt-1.3.2.ebuild,
+ +files/tilt-1.3.2-thread_id.patch:
+ Fix bug with negative object ids, fixes bug 376177.
24 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> tilt-1.3.2.ebuild:
Marked ~ppc wrt #351835
diff --git a/dev-ruby/tilt/files/tilt-1.3.2-thread_id.patch b/dev-ruby/tilt/files/tilt-1.3.2-thread_id.patch
new file mode 100644
index 000000000000..0391d75c4808
--- /dev/null
+++ b/dev-ruby/tilt/files/tilt-1.3.2-thread_id.patch
@@ -0,0 +1,19 @@
+commit a07077f4737754757e99c2d42267f432289ffd13
+Author: Magnus Holm <judofyr@gmail.com>
+Date: Fri Jun 24 10:43:55 2011 +0200
+
+ Fix compilesite test for multiple threads (closes #93)
+
+diff --git a/test/tilt_compilesite_test.rb b/test/tilt_compilesite_test.rb
+index 1ba6433..2944c84 100644
+--- a/test/tilt_compilesite_test.rb
++++ b/test/tilt_compilesite_test.rb
+@@ -39,7 +39,7 @@ class CompileSiteTest < Test::Unit::TestCase
+ locals = { "local#{i}" => 'value' }
+ res = template.render(self, locals)
+ thread_id = Thread.current.object_id
+- res = template.render(self, "local#{thread_id.to_s}" => 'value')
++ res = template.render(self, "local#{thread_id.abs.to_s}" => 'value')
+ rescue => boom
+ main_thread.raise(boom)
+ end
diff --git a/dev-ruby/tilt/tilt-1.3.2.ebuild b/dev-ruby/tilt/tilt-1.3.2.ebuild
index 20ccd3ee567c..cfe172e9731b 100644
--- a/dev-ruby/tilt/tilt-1.3.2.ebuild
+++ b/dev-ruby/tilt/tilt-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/tilt-1.3.2.ebuild,v 1.2 2011/07/24 09:42:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/tilt-1.3.2.ebuild,v 1.3 2011/07/25 18:07:28 graaff Exp $
EAPI=2
@@ -20,6 +20,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
+RUBY_PATCHES=( "${P}-thread_id.patch" )
+
ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
ruby_add_rdepend ">=dev-ruby/builder-2.0.0"