summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/happydoc/ChangeLog9
-rw-r--r--dev-python/happydoc/Manifest7
-rw-r--r--dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch73
-rw-r--r--dev-python/happydoc/happydoc-2.1.ebuild15
4 files changed, 96 insertions, 8 deletions
diff --git a/dev-python/happydoc/ChangeLog b/dev-python/happydoc/ChangeLog
index e2c7b8c8a05e..bf57860c294e 100644
--- a/dev-python/happydoc/ChangeLog
+++ b/dev-python/happydoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/happydoc
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/ChangeLog,v 1.17 2005/10/02 14:09:18 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/ChangeLog,v 1.18 2006/01/10 20:43:27 marienz Exp $
+
+ 10 Jan 2006; Marien Zwart <marienz@gentoo.org>
+ +files/happydoc-2.1-python-2.4-compat.patch, happydoc-2.1.ebuild:
+ Add a patch to make happydoc 2.1 somewhat work with python 2.4.
+ RESTRICT=test because needed files are not distributed.
02 Oct 2005; Aron Griffis <agriffis@gentoo.org> happydoc-2.1.ebuild:
Mark 2.1 stable on ia64
diff --git a/dev-python/happydoc/Manifest b/dev-python/happydoc/Manifest
index 48b001ee560f..d30f2f61a6ec 100644
--- a/dev-python/happydoc/Manifest
+++ b/dev-python/happydoc/Manifest
@@ -1,6 +1,7 @@
-MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 500298b4bf1a8ff17fb488d4c5b9d3b7 ChangeLog 1719
-MD5 65a0c4ac5f9d2d7a70f477edc7300fe6 happydoc-2.0.1.ebuild 778
-MD5 74e727c0353dbc9c5a982bbd6bcebc5d happydoc-2.1.ebuild 938
MD5 ff94dd4cc18291ab80ea2ecbdf87538f files/digest-happydoc-2.0.1 67
MD5 c59f336e6e9e7950b97b32aa34f59d69 files/digest-happydoc-2.1 65
+MD5 ed3b17f88c00bcc8b329783ed9f7c4a1 files/happydoc-2.1-python-2.4-compat.patch 2373
+MD5 65a0c4ac5f9d2d7a70f477edc7300fe6 happydoc-2.0.1.ebuild 778
+MD5 28f7979166abea9fbdb3a28457244d15 happydoc-2.1.ebuild 1116
+MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
diff --git a/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch b/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch
new file mode 100644
index 000000000000..e58f721224bf
--- /dev/null
+++ b/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch
@@ -0,0 +1,73 @@
+=== modified file 'happydoclib/docstring/StructuredText/STDOM.py'
+--- happydoclib/docstring/StructuredText/STDOM.py
++++ happydoclib/docstring/StructuredText/STDOM.py
+@@ -171,7 +171,7 @@
+ type=type,
+ st=type(''),
+ getattr=getattr,
+- None=None):
++ none=None):
+
+ """
+ The node immediately preceding this node. If
+@@ -180,17 +180,17 @@
+
+ children = self.aq_parent.getChildren()
+ if not children:
+- return None
+-
+- index=getattr(self, '_DOMIndex', None)
+- if index is None:
++ return none
++
++ index=getattr(self, '_DOMIndex', none)
++ if index is none:
+ index=self._getDOMIndex(children)
+- if index is None: return None
++ if index is none: return none
+
+ index=index-1
+- if index < 0: return None
++ if index < 0: return none
+ try: n=children[index]
+- except IndexError: return None
++ except IndexError: return none
+ else:
+ if type(n) is st:
+ n=TextNode(n)
+@@ -243,9 +243,9 @@
+ type=type,
+ st=type(''),
+ getattr=getattr,
+- None=None):
+-
+- return self.getPreviousSibling(type,st,getattr,None)
++ none=None):
++
++ return self.getPreviousSibling(type,st,getattr,none)
+
+ def _get_NextSibling(self, type=type, st=type('')):
+ return self.getNextSibling(type,st)
+@@ -292,7 +292,7 @@
+ type=type,
+ st=type(''),
+ getattr=getattr,
+- None=None):
++ none=None):
+ """
+ The node immediately preceding this node. If
+ there is no such node, this returns None.
+@@ -346,9 +346,9 @@
+ type=type,
+ st=type(''),
+ getattr=getattr,
+- None=None):
+-
+- return self.getPreviousSibling(type,st,getattr,None)
++ none=None):
++
++ return self.getPreviousSibling(type,st,getattr,none)
+
+ def _get_NextSibling(self, type=type, st=type('')):
+ return self.getNextSibling()
+
diff --git a/dev-python/happydoc/happydoc-2.1.ebuild b/dev-python/happydoc/happydoc-2.1.ebuild
index 7418e4ef5573..02adb7333b73 100644
--- a/dev-python/happydoc/happydoc-2.1.ebuild
+++ b/dev-python/happydoc/happydoc-2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-2.1.ebuild,v 1.15 2005/10/02 14:09:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-2.1.ebuild,v 1.16 2006/01/10 20:43:27 marienz Exp $
-inherit distutils
+inherit distutils eutils
MY_PN="HappyDoc"
MY_PV=${PV//./_}
@@ -18,6 +18,15 @@ IUSE=""
DEPEND="virtual/python"
+# the tests need extra data not present in the release tarball
+RESTRICT=test
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-python-2.4-compat.patch"
+}
+
src_install() {
mydoc="INSTALL.txt LICENSE.txt CHANGES.txt README.txt"
distutils_src_install