summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog5
-rw-r--r--app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 7b08a4ea18bf..457428ef13f1 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.140 2013/02/11 15:26:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.141 2013/02/12 06:34:04 idella4 Exp $
+
+ 12 Feb 2013; Ian Delaney <idella4@gentoo.org> xen-tools-4.2.1-r2.ebuild:
+ Fixed copy header file, Bug #456884
11 Feb 2013; Ian Delaney <idella4@gentoo.org> xen-tools-4.2.0-r3.ebuild,
xen-tools-4.2.1-r2.ebuild:
diff --git a/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild b/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild
index 1fbb41bb25c6..c238f7c55037 100644
--- a/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild,v 1.4 2013/02/11 15:26:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.1-r2.ebuild,v 1.5 2013/02/12 06:34:04 idella4 Exp $
EAPI=5
@@ -195,7 +195,10 @@ src_prepare() {
#Sec patch, currently valid
epatch "${FILESDIR}"/xen-4-CVE-2012-6075-XSA-41.patch
- use hvm && cp -r "${FILESDIR}"/stubs-32.h xen/tools/include && einfo "stubs-32.h added" || die
+ if use hvm; then
+ cp -r "${FILESDIR}"/stubs-32.h xen/tools/include || die "copy of header file failed"
+ einfo "stubs-32.h added"
+ fi
}
src_compile() {