summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild')
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild b/app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..e6a952e4ba9f
--- /dev/null
+++ b/app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ttyrec/ttyrec-1.0.6-r1.ebuild,v 1.1 2005/11/05 04:08:25 matsuu Exp $
+
+DESCRIPTION="tty recorder"
+HOMEPAGE="http://namazu.org/~satoru/ttyrec/"
+SRC_URI="http://namazu.org/~satoru/ttyrec/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ local mycflags
+ mycflags="${CFLAGS}"
+
+ # Bug 106530.
+ if ! use x86-fbsd && ! use ppc-macos; then
+ mycflags="${CFLAGS} -DSVR4"
+ fi
+ make CFLAGS="${mycflags}" || die
+}
+
+src_install() {
+ dobin ttyrec ttyplay ttytime || die
+ dodoc README
+ doman *.1
+}