summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite/sqlite-2.7.3.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.7.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/sqlite/sqlite-2.7.3.ebuild b/dev-db/sqlite/sqlite-2.7.3.ebuild
new file mode 100644
index 000000000000..04f7c59de2f2
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.7.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.7.3.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
+HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
+DEPEND="virtual/glibc
+ dev-lang/tcl"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc || die
+
+ emake || die
+ make doc || die
+}
+
+src_install () {
+ dodir /usr/{bin,include,lib}
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dobin lemon
+
+ dodoc README VERSION
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}
+