summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imaging/imaging-1.1.3-r2.ebuild')
-rw-r--r--dev-python/imaging/imaging-1.1.3-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/imaging/imaging-1.1.3-r2.ebuild b/dev-python/imaging/imaging-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..e4d02176c4dd
--- /dev/null
+++ b/dev-python/imaging/imaging-1.1.3-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.3-r2.ebuild,v 1.1 2004/07/19 21:50:44 kloeri Exp $
+
+inherit distutils
+
+MY_P=${P/imaging/Imaging}
+S=${WORKDIR}/${MY_P}
+
+IUSE="tcltk"
+
+DESCRIPTION="Python Imaging Library (PIL)."
+SRC_URI="http://www.pythonware.net/storage/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pythonware.com/downloads/#pil"
+
+DEPEND=">=media-libs/jpeg-6a
+ >=sys-libs/zlib-0.95
+ tcltk? ( dev-lang/tk )"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc ~alpha ~ppc"
+LICENSE="as-is"
+
+src_compile() {
+ export OPT=${CFLAGS}
+
+ #Build the core imaging library (libImaging.a)
+ cd ${S}/libImaging
+ econf || die "econf failed"
+ cp Makefile Makefile.orig
+
+ #Not configured by configure
+ sed \
+ -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ Makefile.orig > Makefile
+ emake || die
+ cd ${S}
+ CFLAGS="$(CFLAGS) -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK" distutils_src_compile
+}
+
+src_install ()
+{
+ local mydoc="CHANGES* CONTENTS"
+ distutils_src_install
+ distutils_python_version
+
+ # install headers required by media-gfx/sketch
+ insinto "${ROOT}/usr/include/python${PYVER}"
+ doins libImaging/Imaging.h
+ doins libImaging/ImPlatform.h
+ doins libImaging/ImConfig.h
+}