summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/postfix/postfix-2.5.5.ebuild')
-rw-r--r--mail-mta/postfix/postfix-2.5.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail-mta/postfix/postfix-2.5.5.ebuild b/mail-mta/postfix/postfix-2.5.5.ebuild
index 08ab93d66e51..929dfd2b089d 100644
--- a/mail-mta/postfix/postfix-2.5.5.ebuild
+++ b/mail-mta/postfix/postfix-2.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.5.ebuild,v 1.6 2008/11/09 12:19:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.5.5.ebuild,v 1.7 2009/07/05 20:57:15 gengor Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -250,7 +250,9 @@ src_compile() {
einfo "CC=${my_cc:=gcc}"
# Workaround for bug #76512
- [[ "$(gcc-version)" == "3.4" ]] && use hardened && replace-flags -O? -Os
+ if use hardened ; then
+ [[ "$(gcc-version)" == "3.4" ]] && replace-flags -O? -Os
+ fi
make DEBUG="" CC="${my_cc:=gcc}" OPT="${CFLAGS}" CCARGS="${mycc}" AUXLIBS="${mylibs}" \
makefiles || die "configure problem"