summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/raul/raul-0.4.0.ebuild')
-rw-r--r--media-libs/raul/raul-0.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/raul/raul-0.4.0.ebuild b/media-libs/raul/raul-0.4.0.ebuild
new file mode 100644
index 000000000000..2fa5b10a4d35
--- /dev/null
+++ b/media-libs/raul/raul-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/raul-0.4.0.ebuild,v 1.1 2008/05/29 08:24:48 aballier Exp $
+
+DESCRIPTION="C++ utility library primarily aimed at audio/musical applications."
+HOMEPAGE="http://wiki.drobilla.net/Raul"
+SRC_URI="http://download.drobilla.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc jack lash"
+
+RDEPEND=">=dev-cpp/glibmm-2.4
+ >=dev-libs/glib-2.0
+ dev-libs/boost
+ jack? ( >=media-sound/jack-audio-connection-kit-0.107 )
+ lash? ( >=media-sound/lash-0.5.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable debug pointer-debug) \
+ $(use_enable jack enable-jack) \
+ $(use_enable jack) \
+ $(use_enable lash) \
+ $(use_enable doc documentation)
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+ use doc && dohtml -r doc/html/*
+}