summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-osdteletext/files/vdr-osdteletext-0.5.1-vdr-1.5.patch')
-rw-r--r--media-plugins/vdr-osdteletext/files/vdr-osdteletext-0.5.1-vdr-1.5.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/media-plugins/vdr-osdteletext/files/vdr-osdteletext-0.5.1-vdr-1.5.patch b/media-plugins/vdr-osdteletext/files/vdr-osdteletext-0.5.1-vdr-1.5.patch
deleted file mode 100644
index eef0fe66677c..000000000000
--- a/media-plugins/vdr-osdteletext/files/vdr-osdteletext-0.5.1-vdr-1.5.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -aur osdteletext-0.5.1/Makefile osdteletext/Makefile
---- osdteletext-0.5.1/Makefile 2005-08-08 18:29:22.000000000 +0200
-+++ osdteletext/Makefile 2006-04-23 17:54:49.000000000 +0200
-@@ -20,7 +20,6 @@
-
- ### The directory environment:
-
--DVBDIR = ../../../../DVB
- VDRDIR = ../../..
- LIBDIR = ../../lib
- TMPDIR = /tmp
-@@ -32,6 +31,10 @@
- ### The version number of VDR (taken from VDR's "config.h"):
-
- VDRVERSION = $(shell grep 'define VDRVERSION ' $(VDRDIR)/config.h | awk '{ print $$3 }' | sed -e 's/"//g')
-+APIVERSION = $(shell grep 'define APIVERSION ' $(VDRDIR)/config.h | awk '{ print $$3 }' | sed -e 's/"//g')
-+ifeq ($(strip $(APIVERSION)),)
-+ APIVERSION = $(VDRVERSION)
-+endif
-
- ### The name of the distribution archive:
-
-@@ -40,7 +43,7 @@
-
- ### Includes and Defines (add further entries here):
-
--INCLUDES += -I$(VDRDIR)/include -I$(DVBDIR)/include
-+INCLUDES += -I$(VDRDIR)/include
-
- DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"' -D_GNU_SOURCE
-
-@@ -72,7 +75,7 @@
-
- libvdr-$(PLUGIN).so: $(OBJS)
- $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
-- @cp $@ $(LIBDIR)/$@.$(VDRVERSION)
-+ @cp $@ $(LIBDIR)/$@.$(APIVERSION)
-
- dist: clean
- @-rm -rf $(TMPDIR)/$(ARCHIVE)
-Nur in osdteletext: .svn.
-diff -aur osdteletext-0.5.1/txtrecv.c osdteletext/txtrecv.c
---- osdteletext-0.5.1/txtrecv.c 2005-08-12 13:20:09.000000000 +0200
-+++ osdteletext/txtrecv.c 2007-01-14 00:14:15.667936696 +0100
-@@ -692,7 +692,9 @@
- */
-
- cTxtReceiver::cTxtReceiver(int TPid, tChannelID chan)
--#if VDRVERSNUM >= 10319
-+#if VDRVERSNUM >= 10500
-+ : cReceiver(chan, -1, TPid),
-+#elif VDRVERSNUM >= 10319
- : cReceiver(0, -1, TPid),
- #else
- : cReceiver(0, -1, 1, TPid),