summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/esound/esound-0.2.39.ebuild')
-rw-r--r--media-sound/esound/esound-0.2.39.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-sound/esound/esound-0.2.39.ebuild b/media-sound/esound/esound-0.2.39.ebuild
index b6b4d8e631a6..e39c9772ff65 100644
--- a/media-sound/esound/esound-0.2.39.ebuild
+++ b/media-sound/esound/esound-0.2.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.39.ebuild,v 1.1 2008/07/16 10:33:51 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.39.ebuild,v 1.2 2008/07/21 17:07:00 remi Exp $
inherit libtool gnome.org eutils flag-o-matic
@@ -26,6 +26,13 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
app-admin/eselect-esd"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.2.39-fix-errno.patch"
+}
+
src_compile() {
# Strict aliasing problem
append-flags -fno-strict-aliasing