summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pftpfxp/ChangeLog8
-rw-r--r--net-ftp/pftpfxp/files/0.11.4.6-correct_config_fix.patch94
-rw-r--r--net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.62
-rw-r--r--net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6-r23
-rw-r--r--net-ftp/pftpfxp/pftpfxp-0.11.4.6-r2.ebuild47
5 files changed, 153 insertions, 1 deletions
diff --git a/net-ftp/pftpfxp/ChangeLog b/net-ftp/pftpfxp/ChangeLog
index be76010ebcb3..e8097fe1c86b 100644
--- a/net-ftp/pftpfxp/ChangeLog
+++ b/net-ftp/pftpfxp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/pftpfxp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/ChangeLog,v 1.7 2006/02/24 21:48:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/ChangeLog,v 1.8 2006/07/13 03:05:57 dragonheart Exp $
+
+*pftpfxp-0.11.4.6-r2 (13 Jul 2006)
+
+ 13 Jul 2006; Daniel Black <dragonheart@gentoo.org>
+ +files/0.11.4.6-correct_config_fix.patch, +pftpfxp-0.11.4.6-r2.ebuild:
+ added patch to respect $HOME - inspired by Daniel Persson bug #140143
24 Feb 2006; Daniel Black <dragonheart@gentoo.org>
pftpfxp-0.11.4.6.ebuild, pftpfxp-0.11.4.6-r1.ebuild:
diff --git a/net-ftp/pftpfxp/files/0.11.4.6-correct_config_fix.patch b/net-ftp/pftpfxp/files/0.11.4.6-correct_config_fix.patch
new file mode 100644
index 000000000000..c5d4b6a589f8
--- /dev/null
+++ b/net-ftp/pftpfxp/files/0.11.4.6-correct_config_fix.patch
@@ -0,0 +1,94 @@
+--- pftpfxp-mew/src/main.cc.orig 2006-07-13 13:04:55.000000000 +1000
++++ pftpfxp-mew/src/main.cc 2006-07-13 13:07:35.000000000 +1000
+@@ -547,7 +547,7 @@
+ if ((*label != '\0') && (strlen(value) > 0)) {
+ if (!strcasecmp(label, "DEVICE")) {
+ if (!DetermineOwnIP(value)) {
+- printf("unknown network device '%s', sorry.\n",
++ fprintf(stderr,"unknown network device '%s', sorry.\n",
+ value);
+ fclose(in_file);
+ return (FALSE);
+@@ -705,7 +705,7 @@
+ strcpy(sectionlabels[21], value);
+ //debuglog("section22: %s", sectionlabels[21]);
+ } else {
+- printf("unknown label '%s' in configfile.\n", label);
++ fprintf(stderr,"unknown label '%s' in configfile.\n", label);
+ fclose(in_file);
+ return (FALSE);
+ }
+@@ -1096,9 +1096,26 @@
+ }
+
+ int main(int argc, char **argv) {
+- char msg[256], config_file[] = {".pftp/config"}, keymap_file[] = {".pftp/keymap"};
++ char msg[256];
++ char *home_directory;
++ char *config_file;
++ char *keymap_file;
+ int n;
+
++ home_directory = getenv("HOME");
++ n = strlen(home_directory) + sizeof("/.pftp/config") + 1;
++ if ((config_file=(char*)malloc(n))==NULL) {
++ fprintf(stderr,"error allocating memory\n");
++ exit( -1);
++ }
++ if ((keymap_file=(char*)malloc(n))==NULL) {
++ free(config_file);
++ fprintf(stderr,"error allocating memory\n");
++ exit( -1);
++ }
++ sprintf(config_file, "%s/.pftp/config", home_directory);
++ sprintf(keymap_file, "%s/.pftp/keymap", home_directory);
++
+ pthread_mutex_init(&syscall_lock, NULL);
+ pthread_mutex_init(&sigwinch_lock, NULL);
+
+@@ -1137,35 +1154,39 @@
+ getcwd(startcwd, SERVER_WORKINGDIR_SIZE);
+
+ if (!ReadConfig(config_file)) {
+- printf("error reading/parsing configfile '%s', bailing out.\n", config_file);
++ fprintf(stderr,"error reading/parsing configfile '%s', bailing out.\n", config_file);
++ free(config_file);
+ exit( -1);
+ }
++ free(config_file);
+
+ unlinklog();
+
+ if (!ReadKeymap(keymap_file)) {
+- printf("error reading/parsing keymapfile '%s', bailing out.\n", keymap_file);
++ fprintf(stderr,"error reading/parsing keymapfile '%s', bailing out.\n", keymap_file);
++ free(keymap_file);
+ exit( -1);
+ }
++ free(keymap_file);
+ debuglog("after keymap");
+
+ if (display->ProbeBookmarkRC() == 1) {
+- printf("unknown or invalid bookmark file found, delete it\n");
++ fprintf(stderr,"unknown or invalid bookmark file found, delete it\n");
+ exit( -1);
+ }
+
+ if (chdir(localdir) != 0) {
+- printf("please specify a valid dir for the LOCALDIR label or comment it out\n");
++ fprintf(stderr,"please specify a valid dir for the LOCALDIR label or comment it out\n");
+ exit ( -1);
+ }
+
+ if (!use_own_ip) {
+- printf("you need to specify a network-device in the configfile.\n");
++ fprintf(stderr,"you need to specify a network-device in the configfile.\n");
+ exit( -1);
+ }
+
+ if (!use_okay_dir) {
+- printf("you need to specify a dir for the .okay and .error files in the configfile.\n");
++ fprintf(stderr,"you need to specify a dir for the .okay and .error files in the configfile.\n");
+ exit( -1);
+ }
+
diff --git a/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6 b/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6
index 66deec50372c..923a4fd4b307 100644
--- a/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6
+++ b/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6
@@ -1 +1,3 @@
MD5 22528192327488a372a6de1f5d2709dc pftpfxp-v0.11.4mew6.tgz 137093
+RMD160 7d60f8cb2469d7bb95561631c05a5692dccde995 pftpfxp-v0.11.4mew6.tgz 137093
+SHA256 c119435cd844eda76631dde77104e2d0daeef44923158776927d3b51dd5b1e9b pftpfxp-v0.11.4mew6.tgz 137093
diff --git a/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6-r2 b/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6-r2
new file mode 100644
index 000000000000..923a4fd4b307
--- /dev/null
+++ b/net-ftp/pftpfxp/files/digest-pftpfxp-0.11.4.6-r2
@@ -0,0 +1,3 @@
+MD5 22528192327488a372a6de1f5d2709dc pftpfxp-v0.11.4mew6.tgz 137093
+RMD160 7d60f8cb2469d7bb95561631c05a5692dccde995 pftpfxp-v0.11.4mew6.tgz 137093
+SHA256 c119435cd844eda76631dde77104e2d0daeef44923158776927d3b51dd5b1e9b pftpfxp-v0.11.4mew6.tgz 137093
diff --git a/net-ftp/pftpfxp/pftpfxp-0.11.4.6-r2.ebuild b/net-ftp/pftpfxp/pftpfxp-0.11.4.6-r2.ebuild
new file mode 100644
index 000000000000..85133d6b9e88
--- /dev/null
+++ b/net-ftp/pftpfxp/pftpfxp-0.11.4.6-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pftpfxp/pftpfxp-0.11.4.6-r2.ebuild,v 1.1 2006/07/13 03:05:57 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The powerful curses-based ftp/fxp client, mew edition"
+HOMEPAGE="http://pftpmew.tanesha.net"
+SRC_URI="http://tanesha.net/bigmess/pftpfxp-v0.11.4mew6.tgz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )"
+S=${WORKDIR}/pftpfxp-mew
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.4.fix || die "patch failed"
+ epatch ${FILESDIR}/pftpfxp-v0.11.4mew6-pret.patch || die "patch failed"
+ epatch ${FILESDIR}/0.11.4.6-correct_config_fix.patch || die "patch failed"
+ sed -i -e "s/^CPP=.*/CPP=$(tc-getCXX)/" \
+ -e "s:^CPPF=.*:CPPF=\"-Wall -D_REENTRANT -I../include ${CFLAGS}\":" \
+ configure
+}
+
+src_compile() {
+ cd ${S}
+ #note: not a propper autoconf
+ ./configure || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin pftp
+ dodoc .pftp/config .pftp/keymap README.MEW old/*
+ cd ${WORKDIR}
+ mv irssi mIRC-mew pftpfxp-autoconnect ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ einfo "In order to use pftp-mew you need to create these files:"
+ einfo " ~/.pftp/config"
+ einfo " ~/.pftp/keymap"
+ einfo "Refer to the examples in /usr/share/doc/${PF} for more information."
+}