summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/vnc/vnc-3.3.7.ebuild')
-rw-r--r--net-misc/vnc/vnc-3.3.7.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/vnc/vnc-3.3.7.ebuild b/net-misc/vnc/vnc-3.3.7.ebuild
new file mode 100644
index 000000000000..72ffdac01cf9
--- /dev/null
+++ b/net-misc/vnc/vnc-3.3.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.7.ebuild,v 1.1 2003/03/24 15:38:19 phosphan Exp $
+
+inherit eutils
+
+IUSE="java tcpd"
+
+MY_P="${P}-unixsrc"
+
+DESCRIPTION="Remote desktop viewer display system"
+HOMEPAGE="http://www.realvnc.com/"
+
+SRC_URI="http://www.realvnc.com/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="java? ( virtual/jre )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.security.patch
+}
+
+src_compile() {
+
+ export CXX="g++"
+
+ econf || die "./configure failed"
+
+ make
+
+ cd Xvnc
+ if use tcpd
+ then
+ make \
+ EXTRA_LIBRARIES="-lwrap -lnss_nis" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ World || die
+ else
+ make \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ World || die
+ fi
+
+}
+
+src_install () {
+
+ dodir /usr/bin /usr/share/man/man1
+
+ ./vncinstall ${D}/usr/bin ${D}/usr/share/man || die
+
+ if use java
+ then
+ cd ${S}/classes
+ insinto /usr/share/vnc/classes
+ doins *.class *.jar *.vnc
+ fi
+
+ cd ${S}
+ dodoc LICENCE.TXT README
+
+}
+