summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/apache/apache-2.0.55-r1.ebuild')
-rw-r--r--net-www/apache/apache-2.0.55-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-www/apache/apache-2.0.55-r1.ebuild b/net-www/apache/apache-2.0.55-r1.ebuild
index 1a51e1f34717..90ac9bf2e309 100644
--- a/net-www/apache/apache-2.0.55-r1.ebuild
+++ b/net-www/apache/apache-2.0.55-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.55-r1.ebuild,v 1.10 2006/04/17 16:19:12 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.55-r1.ebuild,v 1.11 2006/04/19 17:24:59 chtekk Exp $
inherit eutils gnuconfig multilib
@@ -180,11 +180,13 @@ src_compile() {
fi
}
-src_install () {
+pkg_preinst() {
# setup apache user and group
enewgroup apache 81
enewuser apache 81 -1 /var/www apache
+}
+src_install () {
# general install
make DESTDIR=${D} install || die
dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt