summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/celestia/celestia-1.6.0.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index 6d328679280e..0e659ac101d7 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.11 2010/03/08 18:24:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.12 2010/06/24 17:20:48 xarthisius Exp $
EAPI=2
inherit eutils flag-o-matic gnome2 autotools
@@ -58,8 +58,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.1-gcc44.patch
# needed for proper detection of kde-3.5 in the presence
# of kde4
- epatch "${FILESDIR}"/${P}-kde-3.5.patch
- epatch "${FILESDIR}"/${P}-libpng14.patch
+ epatch "${FILESDIR}"/${P}-kde-3.5.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-parallel_install.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \